summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/bc-gh/bc-gh-3.1.6.ebuild')
-rw-r--r--sci-calculators/bc-gh/bc-gh-3.1.6.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/sci-calculators/bc-gh/bc-gh-3.1.6.ebuild b/sci-calculators/bc-gh/bc-gh-3.1.6.ebuild
new file mode 100644
index 000000000000..31daa94bd5ce
--- /dev/null
+++ b/sci-calculators/bc-gh/bc-gh-3.1.6.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Implementation of POSIX bc with GNU extensions"
+HOMEPAGE="https://github.com/gavinhoward/bc"
+SRC_URI="https://github.com/gavinhoward/bc/releases/download/${PV}/bc-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+S="${WORKDIR}/bc-${PV}"
+
+src_configure() {
+ EXECSUFFIX="-gh" PREFIX="${EPREFIX}/usr" ./configure.sh -GTl || die
+}