summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/units/units-2.18.ebuild')
-rw-r--r--sci-calculators/units/units-2.18.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-calculators/units/units-2.18.ebuild b/sci-calculators/units/units-2.18.ebuild
index 4d61f6f6676c..3df5a8826c27 100644
--- a/sci-calculators/units/units-2.18.ebuild
+++ b/sci-calculators/units/units-2.18.ebuild
@@ -12,12 +12,12 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="FDL-1.3 GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+units_cur"
-REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+units--cur"
+REQUIRED_USE="units--cur? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
sys-libs/readline:=
- units_cur? (
+ units--cur? (
${PYTHON_DEPS}
dev-python/future[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
@@ -31,7 +31,7 @@ PATCHES=(
)
pkg_setup() {
- use units_cur && python-single-r1_pkg_setup
+ use units--cur && python-single-r1_pkg_setup
}
src_configure() {
@@ -52,7 +52,7 @@ src_install() {
# we're intentionally delaying this since 'make install' would
# get confused if we shove 'units_cur' there, and there is no real
# need to add more complexity for it
- if use units_cur; then
+ if use units--cur; then
sed \
-e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
-e 's|^#!|&/usr/bin/python|g' \