summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/MDAnalysis/MDAnalysis-0.18.0-r1.ebuild')
-rw-r--r--sci-chemistry/MDAnalysis/MDAnalysis-0.18.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-chemistry/MDAnalysis/MDAnalysis-0.18.0-r1.ebuild b/sci-chemistry/MDAnalysis/MDAnalysis-0.18.0-r1.ebuild
new file mode 100644
index 000000000000..0e9af8987fab
--- /dev/null
+++ b/sci-chemistry/MDAnalysis/MDAnalysis-0.18.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python library to analyze and manipulate molecular dynamics trajectories"
+HOMEPAGE="https://www.mdanalysis.org"
+SRC_URI="mirror://pypi/M/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-biology/biopython[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/GridDataFormats[${PYTHON_USEDEP}]
+ dev-python/netcdf4-python[${PYTHON_USEDEP}]
+ dev-python/mmtf-python[${PYTHON_USEDEP}]
+ dev-python/gsd[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/duecredit[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="!test? ( test )"