summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/chemex/chemex-2021.4.0_p4.ebuild')
-rw-r--r--sci-chemistry/chemex/chemex-2021.4.0_p4.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/sci-chemistry/chemex/chemex-2021.4.0_p4.ebuild b/sci-chemistry/chemex/chemex-2021.4.0_p4.ebuild
deleted file mode 100644
index 3a331d48eba7..000000000000
--- a/sci-chemistry/chemex/chemex-2021.4.0_p4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-DISTUTILS_SINGLE_IMPL="yes"
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-
-inherit distutils-r1
-
-DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
-HOMEPAGE="https://github.com/gbouvignies/chemex"
-SRC_URI="https://github.com/gbouvignies/chemex/archive/${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64"
-IUSE="test"
-
-#RESTRICT="!test? ( test )"
-# FIXME: Restrict until we figure out how to run tests properly, bug #815079
-RESTRICT="test"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/asteval-0.9.25[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.1.0[${PYTHON_USEDEP}]
- >=dev-python/lmfit-1.0.3[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-3.4.3[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.21.2[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.7.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.7.2[${PYTHON_USEDEP}]
- >=dev-python/tqdm-4.61.1[${PYTHON_USEDEP}]
- ')
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest
-
-S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
-
-src_prepare() {
- export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
- distutils-r1_src_prepare
-}