summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/files/gromacs-2020_beta1-pytest.patch')
-rw-r--r--sci-chemistry/gromacs/files/gromacs-2020_beta1-pytest.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/sci-chemistry/gromacs/files/gromacs-2020_beta1-pytest.patch b/sci-chemistry/gromacs/files/gromacs-2020_beta1-pytest.patch
new file mode 100644
index 000000000000..452987f38b96
--- /dev/null
+++ b/sci-chemistry/gromacs/files/gromacs-2020_beta1-pytest.patch
@@ -0,0 +1,12 @@
+diff -urN gromacs-2020-beta1/python_packaging/src/CMakeLists.txt gromacs-2020-beta1-py/python_packaging/src/CMakeLists.txt
+--- gromacs-2020-beta1/python_packaging/src/CMakeLists.txt 2019-09-12 05:48:57.000000000 +0300
++++ gromacs-2020-beta1-py/python_packaging/src/CMakeLists.txt 2019-10-09 17:01:30.845304765 +0300
+@@ -201,5 +201,7 @@
+ # to the `check` target. Normal usage is to first install the Python package,
+ # then run `pytest` on the `tests` directory. Refer to gmxapi package documentation.
+ if(NOT GMXAPI_MASTER_PROJECT)
+- add_subdirectory(test)
++ if (GMX_BUILD_TESTING)
++ add_subdirectory(test)
++ endif()
+ endif()