summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild b/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
index cacbc3eef174..b04308aaa907 100644
--- a/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
@@ -61,9 +61,11 @@ RESTRICT="!test? ( test )"
S="${WORKDIR}/${PN}-${PV/_/-}"
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {