summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/votca-csg/votca-csg-9999.ebuild')
-rw-r--r--sci-chemistry/votca-csg/votca-csg-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-chemistry/votca-csg/votca-csg-9999.ebuild b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
index 2fd3e86a4083..ba2fbdfd7aa7 100644
--- a/sci-chemistry/votca-csg/votca-csg-9999.ebuild
+++ b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
@@ -20,7 +20,8 @@ HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="examples extras +gromacs hdf5"
+IUSE="examples extras +gromacs hdf5 test"
+RESTRICT="!test? ( test )"
RDEPEND="
app-shells/bash:*
@@ -56,6 +57,7 @@ src_configure() {
-DCMAKE_DISABLE_FIND_PACKAGE_GROMACS=$(usex !gromacs)
-DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
-DBUILD_CSGAPPS=$(usex extras)
+ -DENABLE_TESTING=$(usex test)
)
cmake_src_configure
}