summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/votca-ctp/votca-ctp-9999.ebuild')
-rw-r--r--sci-chemistry/votca-ctp/votca-ctp-9999.ebuild33
1 files changed, 30 insertions, 3 deletions
diff --git a/sci-chemistry/votca-ctp/votca-ctp-9999.ebuild b/sci-chemistry/votca-ctp/votca-ctp-9999.ebuild
index 4e400a2318b7..892997f7af3e 100644
--- a/sci-chemistry/votca-ctp/votca-ctp-9999.ebuild
+++ b/sci-chemistry/votca-ctp/votca-ctp-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,9 +7,10 @@ CMAKE_MAKEFILE_GENERATOR="ninja"
inherit cmake-utils multilib
-IUSE=""
+IUSE="doc"
if [ "${PV}" != "9999" ]; then
- SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://github.com/${PN/-//}/releases/download/v${PV}/${PN}-manual-${PV}.pdf )"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
S="${WORKDIR}/${P#votca-}"
else
@@ -33,8 +34,34 @@ RDEPEND="
DEPEND="${RDEPEND}
virtual/pkgconfig"
+if [ "${PV}" != "9999" ]; then
+ DEPEND="${DEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ dev-tex/pgf
+ )"
+fi
+
DOCS=( README.md NOTICE CHANGELOG.md )
+src_configure() {
+ [[ ${PV} = *9999* ]] && mycmakeargs=(
+ -DBUILD_XTP_MANUAL=$(usex doc)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ [[ ${PV} != *9999* ]] && dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
+ cmake-utils_src_make -C "${CMAKE_BUILD_DIR}" html
+ dodoc -r "${CMAKE_BUILD_DIR}"/share/doc/html
+ fi
+}
+
pkg_postinst() {
einfo
einfo "Please read and cite:"