summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/electric/files/electric-7.00-qt-gentoo.patch')
-rw-r--r--sci-electronics/electric/files/electric-7.00-qt-gentoo.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-electronics/electric/files/electric-7.00-qt-gentoo.patch b/sci-electronics/electric/files/electric-7.00-qt-gentoo.patch
new file mode 100644
index 000000000000..f21c4c5e577a
--- /dev/null
+++ b/sci-electronics/electric/files/electric-7.00-qt-gentoo.patch
@@ -0,0 +1,48 @@
+diff -Naur electric-7.00/Makefile.in electric-7.00-new/Makefile.in
+--- electric-7.00/Makefile.in 2004-07-15 20:59:50.000000000 -0500
++++ electric-7.00-new/Makefile.in 2006-03-15 22:19:08.000000000 -0600
+@@ -1,10 +1,10 @@
+ ########################################################## USING QT
+ ##### If using Qt, uncomment these five lines
+-# GRAPH_FLAGS = -DUSEQT -DQT_THREAD_SUPPORT -I$(QTDIR)/include $(QUI_CFLAGS)
+-# GRAPH_LIBS = -L$(QTDIR)/lib $(QUI_LIBS) $(QT_LIB_EXTRAS)
+-# GRAPH_OBJS = $(GRAPH_OBJS_QT)
+-# GRAPH_SRC = $(GRAPH_SRC_QT)
+-# CCOMPILER = @CXX@
++GRAPH_FLAGS = -DUSEQT -DQT_THREAD_SUPPORT -I$(QTDIR)/include $(QUI_CFLAGS)
++GRAPH_LIBS = -L$(QTDIR)/lib $(QUI_LIBS) $(QT_LIB_EXTRAS)
++GRAPH_OBJS = $(GRAPH_OBJS_QT)
++GRAPH_SRC = $(GRAPH_SRC_QT)
++CCOMPILER = @CXX@
+
+ ##### Qt on UNIX/Linux: uncomment the next two lines:
+ ELECTRIC_TARGET = electric-target-unix
+@@ -20,11 +20,11 @@
+
+ ########################################################### USING MOTIF
+ ##### If using Motif (or OpenMotif/Lesstif), uncomment these five lines
+-GRAPH_FLAGS = @X_CFLAGS@
+-GRAPH_LIBS = -lXm @XMULIB@ -lXt @XPLIB@ @XEXTLIB@ -lX11
+-GRAPH_OBJS = $(GRAPH_OBJS_XT)
+-GRAPH_SRC = $(GRAPH_SRC_XT)
+-CCOMPILER = @PTHREAD_CC@
++#GRAPH_FLAGS = @X_CFLAGS@
++#GRAPH_LIBS = -lXm @XMULIB@ -lXt @XPLIB@ @XEXTLIB@ -lX11
++#GRAPH_OBJS = $(GRAPH_OBJS_XT)
++#GRAPH_SRC = $(GRAPH_SRC_XT)
++#CCOMPILER = @PTHREAD_CC@
+
+ ##### For the general-purpose X facility, uncomment this line
+ XPOWER = -DANYDEPTH
+@@ -997,9 +997,9 @@
+ src/graph/graphqtdlg.o: src/graph/graphqtdlg.cpp $(HDS)/global.h src/graph/graphqtdlg.h $(HDS)/edialogs.h
+ src/graph/graphqtdraw.o: src/graph/graphqtdraw.cpp $(HDS)/global.h src/graph/graphqt.h $(HDS)/egraphics.h
+ src/graph/moc_graphqt.cpp: src/graph/graphqt.h $(HDS)/global.h
+- moc src/graph/graphqt.h -o $@
++ $(QTDIR)/bin/moc src/graph/graphqt.h -o $@
+ src/graph/moc_graphqtdlg.cpp: src/graph/graphqtdlg.h $(HDS)/global.h
+- moc src/graph/graphqtdlg.h -o $@
++ $(QTDIR)/bin/moc src/graph/graphqtdlg.h -o $@
+ $(JARLOC): $(JAVA_OBJS)
+ (cd src/java; jar -cf ../../$(JARLOC) com/sun/dbmirror/*.class)
+ lib/java/romgen.class: lib/java/romgen.java