summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gazebo')
-rw-r--r--sci-electronics/gazebo/Manifest6
-rw-r--r--sci-electronics/gazebo/files/gv10.patch45
-rw-r--r--sci-electronics/gazebo/files/protobuf.patch226
-rw-r--r--sci-electronics/gazebo/files/qwt.patch17
-rw-r--r--sci-electronics/gazebo/files/qwt2.patch17
-rw-r--r--sci-electronics/gazebo/gazebo-11.13.0.ebuild (renamed from sci-electronics/gazebo/gazebo-11.5.1-r3.ebuild)19
-rw-r--r--sci-electronics/gazebo/gazebo-11.14.0.ebuild (renamed from sci-electronics/gazebo/gazebo-11.3.0-r3.ebuild)19
-rw-r--r--sci-electronics/gazebo/gazebo-11.7.0-r2.ebuild83
-rw-r--r--sci-electronics/gazebo/gazebo-11.9.1.ebuild83
9 files changed, 310 insertions, 205 deletions
diff --git a/sci-electronics/gazebo/Manifest b/sci-electronics/gazebo/Manifest
index 6ec5847ce800..975f179885b5 100644
--- a/sci-electronics/gazebo/Manifest
+++ b/sci-electronics/gazebo/Manifest
@@ -1,4 +1,2 @@
-DIST gazebo-11.3.0.tar.bz2 56778002 BLAKE2B d466556c834935d8b3694461ddf6d7a7872b00d2f8f58d50d70cceb8bca3ab4ada1e72e7bb14b79404d45c48f95419e3dedd9019ecc3a8c1623afda077bcbeb2 SHA512 2e219655e45a787aeda50065dcec5d90954c18223f134d6da90b8cb43e119268262e515e527547d0b0b5ed1f73b5083d279551a01faa3d3c34ba7a580c077970
-DIST gazebo-11.5.1.tar.bz2 56486174 BLAKE2B c1bffc5067f2739a8eb2e178bb2209d9c7b5a58d0589710cc515c4bcbbca281fb94ddf16de977f3771bc4b64fb6afe8e86327dde00d19ef62754e4d7634bb65f SHA512 7c922963881cf079e926c239f510e722fc6cabd07ef5e846a4b78772364a3aecb0b68f2b690ff451d42ceb11e88e2f831c30515e5a228f12826516ecad10e53a
-DIST gazebo-11.7.0.tar.bz2 56394312 BLAKE2B 2da58a2702113c1954f0202bb779b723ad8e59cab678f9ca6fe64908785198b996ef71c845a1a85f00e2f4eddb9ed5683f815ada850917b2af4afad214eac77d SHA512 7de40908a021655b2a200a73cf979585f4bdb245064f7e9a853998f87df329223252c73882aa1e2b705bc7de5841e2a87d67f772dfef18e5735c1b06c2663192
-DIST gazebo-11.9.1.tar.bz2 56472954 BLAKE2B c7a1c3c4a03112a90e8a0cb35dde32f5bb478dafb0d8c582d8cbad15ff1f43699782df3d69a75c47efec44d8a15ad96730f1ae9c1b5b0b1ff2099fbc6b8f2e4e SHA512 51af82305ef0758950e2752624cd98bd31abe55469a1cad6432b1edde1a8f896798a554c672f8694c080f7076d13fe1aa91b182227e26f04cb99e9e0f3907694
+DIST gazebo-11.13.0.tar.bz2 56636967 BLAKE2B 7c0ef875711e832a213631d97584edc2300d25be6d538d6f2ac782ab279b6518e1fb7c59d895a1c7b92fbaec46bb0e7c505afb34f05ab2eece016f5bd15a7c3f SHA512 a77ce4a02f723c615738d11a13aa10fa5124705bc9ca95153477d8df25b296eef7d442769379d3888a9ba0f04c1e5a3e38d686e7b5eef393b91bdc78f792c390
+DIST gazebo-11.14.0.tar.bz2 56640328 BLAKE2B 9712118339593edd6c3cc1321ffa3d60f9f986abecc858d0709a0ddd1600a00620b26141300083dcfbc8ff699ae01a21340190cda04b276d146e93ccd1bfc6dc SHA512 365bda1be67745b6b40834a059f220351559e962df5f7254c80d363a04cc4beb092d20eaa357469d87f64c00fd3c6b2480693d7b1d734b0b42a75eb0ba687e34
diff --git a/sci-electronics/gazebo/files/gv10.patch b/sci-electronics/gazebo/files/gv10.patch
new file mode 100644
index 000000000000..f3ab5eb1e686
--- /dev/null
+++ b/sci-electronics/gazebo/files/gv10.patch
@@ -0,0 +1,45 @@
+From 660ae15f4af1f5ea8d9d50d4a24e4d91a94f9c2d Mon Sep 17 00:00:00 2001
+From: Steve Peters <scpeters@openrobotics.org>
+Date: Tue, 20 Feb 2024 17:25:23 -0800
+Subject: [PATCH] Fix build with graphviz 10.0
+
+Replace TRUE with 1, since the TRUE macro has been removed.
+
+Signed-off-by: Steve Peters <scpeters@openrobotics.org>
+---
+ gazebo/gui/qgv/QGVSubGraph.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/gazebo/gui/qgv/QGVSubGraph.cpp b/gazebo/gui/qgv/QGVSubGraph.cpp
+index 51925aba30..c16b69d065 100644
+--- a/gazebo/gui/qgv/QGVSubGraph.cpp
++++ b/gazebo/gui/qgv/QGVSubGraph.cpp
+@@ -44,13 +44,13 @@ QString QGVSubGraph::name() const
+
+ QGVNode *QGVSubGraph::addNode(const QString &label)
+ {
+- Agnode_t *node = agnode(_sgraph->graph(), NULL, TRUE);
++ Agnode_t *node = agnode(_sgraph->graph(), NULL, 1);
+ if (node == NULL)
+ {
+ qWarning()<<"Invalid sub node :"<<label;
+ return 0;
+ }
+- agsubnode(_sgraph->graph(), node, TRUE);
++ agsubnode(_sgraph->graph(), node, 1);
+
+ QGVNode *item = new QGVNode(new QGVNodePrivate(node), _scene);
+ item->setLabel(label);
+@@ -66,10 +66,10 @@ QGVSubGraph *QGVSubGraph::addSubGraph(const QString &_name, bool cluster)
+ if (cluster)
+ {
+ sgraph = agsubg(_sgraph->graph(),
+- ("cluster_" + _name).toLocal8Bit().data(), TRUE);
++ ("cluster_" + _name).toLocal8Bit().data(), 1);
+ }
+ else
+- sgraph = agsubg(_sgraph->graph(), _name.toLocal8Bit().data(), TRUE);
++ sgraph = agsubg(_sgraph->graph(), _name.toLocal8Bit().data(), 1);
+
+ if (sgraph == NULL)
+ {
diff --git a/sci-electronics/gazebo/files/protobuf.patch b/sci-electronics/gazebo/files/protobuf.patch
new file mode 100644
index 000000000000..c815d7a9aab3
--- /dev/null
+++ b/sci-electronics/gazebo/files/protobuf.patch
@@ -0,0 +1,226 @@
+From 92a44c60e4b38d147fd92ed480e33e61cc68c928 Mon Sep 17 00:00:00 2001
+From: Silvio Traversaro <silvio@traversaro.it>
+Date: Tue, 6 Jun 2023 13:50:07 +0200
+Subject: [PATCH 1/6] Support for protobuf >= 22 by using find_package(Protobuf
+ CONFIG)
+
+---
+ cmake/SearchForStuff.cmake | 49 +++++++++++++++++++++++++-----------
+ cmake/gazebo-config.cmake.in | 15 ++++++++---
+ 2 files changed, 46 insertions(+), 18 deletions(-)
+
+diff --git a/cmake/SearchForStuff.cmake b/cmake/SearchForStuff.cmake
+index b1cb3f37b3..e0fbd68274 100644
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -25,29 +25,48 @@ if (CMAKE_BUILD_TYPE)
+ endif()
+
+ ########################################
+-if (PROTOBUF_VERSION LESS 2.3.0)
++if (DEFINED PROTOBUF_VERSION AND PROTOBUF_VERSION GREATER_EQUAL 22.0)
+ BUILD_ERROR("Incorrect version: Gazebo requires protobuf version 2.3.0 or greater")
+ endif()
+
+ ########################################
+ # The Google Protobuf library for message generation + serialization
+-find_package(Protobuf REQUIRED)
+-if (NOT PROTOBUF_FOUND)
+- BUILD_ERROR ("Missing: Google Protobuf (libprotobuf-dev)")
+-endif()
+-if (NOT PROTOBUF_PROTOC_EXECUTABLE)
+- BUILD_ERROR ("Missing: Google Protobuf Compiler (protobuf-compiler)")
+-endif()
+-if (NOT PROTOBUF_PROTOC_LIBRARY)
+- BUILD_ERROR ("Missing: Google Protobuf Compiler Library (libprotoc-dev)")
++
++# Protobuf >= 22 requires to link abseil, so we are constrained to use
++# find_package(Protobuf) and link to protobuf::libprotobuf,
++# see https://github.com/conda-forge/conda-forge-pinning-feedstock/issues/4075#issuecomment-1569242816
++if (DEFINED PROTOBUF_VERSION AND PROTOBUF_VERSION GREATER_EQUAL 22.0)
++ set(GZ_PROTOBUF_USE_CMAKE_CONFIG_DEFAULT ON)
++else()
++ set(GZ_PROTOBUF_USE_CMAKE_CONFIG_DEFAULT OFF)
+ endif()
++option(GZ_PROTOBUF_USE_CMAKE_CONFIG "If true use protobuf-config.cmake to find protobuf" ${GZ_PROTOBUF_USE_CMAKE_CONFIG_DEFAULT})
++mark_as_advanced(GZ_PROTOBUF_USE_CMAKE_CONFIG)
+
+-if ("${CMAKE_BUILD_TYPE}" STREQUAL "Debug")
+- set (GZ_PROTOBUF_LIBRARY ${PROTOBUF_LIBRARY_DEBUG})
+- set (GZ_PROTOBUF_PROTOC_LIBRARY ${PROTOBUF_PROTOC_LIBRARY_DEBUG})
++if(NOT GZ_PROTOBUF_USE_CMAKE_CONFIG)
++ find_package(Protobuf REQUIRED)
++ if (NOT PROTOBUF_FOUND)
++ BUILD_ERROR ("Missing: Google Protobuf (libprotobuf-dev)")
++ endif()
++ if (NOT PROTOBUF_PROTOC_EXECUTABLE)
++ BUILD_ERROR ("Missing: Google Protobuf Compiler (protobuf-compiler)")
++ endif()
++ if (NOT PROTOBUF_PROTOC_LIBRARY)
++ BUILD_ERROR ("Missing: Google Protobuf Compiler Library (libprotoc-dev)")
++ endif()
++ if ("${CMAKE_BUILD_TYPE}" STREQUAL "Debug")
++ set (GZ_PROTOBUF_LIBRARY ${PROTOBUF_LIBRARY_DEBUG})
++ set (GZ_PROTOBUF_PROTOC_LIBRARY ${PROTOBUF_PROTOC_LIBRARY_DEBUG})
++ else()
++ set (GZ_PROTOBUF_LIBRARY ${PROTOBUF_LIBRARY})
++ set (GZ_PROTOBUF_PROTOC_LIBRARY ${PROTOBUF_PROTOC_LIBRARY})
++ endif()
+ else()
+- set (GZ_PROTOBUF_LIBRARY ${PROTOBUF_LIBRARY})
+- set (GZ_PROTOBUF_PROTOC_LIBRARY ${PROTOBUF_PROTOC_LIBRARY})
++ set (GZ_PROTOBUF_LIBRARY protobuf::libprotobuf)
++ set (GZ_PROTOBUF_PROTOC_LIBRARY protobuf::libprotoc)
++ if(NOT DEFINED PROTOBUF_PROTOC_LIBRARY)
++ get_target_property(PROTOBUF_PROTOC_LIBRARY protobuf::protoc LOCATION)
++ endif()
+ endif()
+
+ ########################################
+diff --git a/cmake/gazebo-config.cmake.in b/cmake/gazebo-config.cmake.in
+index 96993f93fa..ac1de2c061 100644
+--- a/cmake/gazebo-config.cmake.in
++++ b/cmake/gazebo-config.cmake.in
+@@ -166,9 +166,18 @@ list(APPEND @PKG_NAME@_INCLUDE_DIRS ${Boost_INCLUDE_DIRS})
+ list(APPEND @PKG_NAME@_LIBRARIES ${Boost_LIBRARIES})
+
+ # Find protobuf
+-find_package(Protobuf REQUIRED)
+-list(APPEND @PKG_NAME@_INCLUDE_DIRS ${PROTOBUF_INCLUDE_DIRS})
+-list(APPEND @PKG_NAME@_LIBRARIES ${PROTOBUF_LIBRARIES})
++set(GZ_PROTOBUF_USE_CMAKE_CONFIG @GZ_PROTOBUF_USE_CMAKE_CONFIG@)
++
++if(NOT GZ_PROTOBUF_USE_CMAKE_CONFIG)
++ find_package(Protobuf REQUIRED)
++ list(APPEND @PKG_NAME@_INCLUDE_DIRS ${PROTOBUF_INCLUDE_DIRS})
++ list(APPEND @PKG_NAME@_LIBRARIES ${PROTOBUF_LIBRARIES})
++else()
++ find_package(Protobuf CONFIG REQUIRED)
++ list(APPEND @PKG_NAME@_INCLUDE_DIRS ${PROTOBUF_INCLUDE_DIRS})
++ list(APPEND @PKG_NAME@_LIBRARIES protobuf::libprotoc)
++ list(APPEND @PKG_NAME@_LIBRARIES protobuf::libprotobuf)
++endif()
+
+ # Find SDFormat
+ find_package(sdformat9 REQUIRED VERSION 9.8)
+
+From 83f05b7778ff2933d8bd3b9149207dd17a20b9b4 Mon Sep 17 00:00:00 2001
+From: Silvio Traversaro <silvio@traversaro.it>
+Date: Tue, 6 Jun 2023 14:18:48 +0200
+Subject: [PATCH 2/6] Update SearchForStuff.cmake
+
+---
+ cmake/SearchForStuff.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/SearchForStuff.cmake b/cmake/SearchForStuff.cmake
+index e0fbd68274..d25b7a4a63 100644
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -25,7 +25,7 @@ if (CMAKE_BUILD_TYPE)
+ endif()
+
+ ########################################
+-if (DEFINED PROTOBUF_VERSION AND PROTOBUF_VERSION GREATER_EQUAL 22.0)
++if (PROTOBUF_VERSION LESS 2.3.0)
+ BUILD_ERROR("Incorrect version: Gazebo requires protobuf version 2.3.0 or greater")
+ endif()
+
+
+From 398e832301429b2f406a5a0e35187ca8fabd50ad Mon Sep 17 00:00:00 2001
+From: Silvio Traversaro <silvio@traversaro.it>
+Date: Tue, 6 Jun 2023 23:25:06 +0200
+Subject: [PATCH 3/6] Update SearchForStuff.cmake
+
+---
+ cmake/SearchForStuff.cmake | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cmake/SearchForStuff.cmake b/cmake/SearchForStuff.cmake
+index d25b7a4a63..2f0b53358f 100644
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -62,6 +62,7 @@ if(NOT GZ_PROTOBUF_USE_CMAKE_CONFIG)
+ set (GZ_PROTOBUF_PROTOC_LIBRARY ${PROTOBUF_PROTOC_LIBRARY})
+ endif()
+ else()
++ find_package(Protobuf CONFIG REQUIRED)
+ set (GZ_PROTOBUF_LIBRARY protobuf::libprotobuf)
+ set (GZ_PROTOBUF_PROTOC_LIBRARY protobuf::libprotoc)
+ if(NOT DEFINED PROTOBUF_PROTOC_LIBRARY)
+
+From d46bf2353a25b38b9613b67f2567f729e133d2b7 Mon Sep 17 00:00:00 2001
+From: Silvio Traversaro <silvio@traversaro.it>
+Date: Tue, 6 Jun 2023 23:55:22 +0200
+Subject: [PATCH 4/6] Update SearchForStuff.cmake
+
+---
+ cmake/SearchForStuff.cmake | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/cmake/SearchForStuff.cmake b/cmake/SearchForStuff.cmake
+index 2f0b53358f..1bbadd3c29 100644
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -66,7 +66,9 @@ else()
+ set (GZ_PROTOBUF_LIBRARY protobuf::libprotobuf)
+ set (GZ_PROTOBUF_PROTOC_LIBRARY protobuf::libprotoc)
+ if(NOT DEFINED PROTOBUF_PROTOC_LIBRARY)
+- get_target_property(PROTOBUF_PROTOC_LIBRARY protobuf::protoc LOCATION)
++ get_target_property(PROTOBUF_PROTOC_LIBRARY_VAR protobuf::protoc LOCATION)
++ set(PROTOBUF_PROTOC_LIBRARY ${PROTOBUF_PROTOC_LIBRARY_VAR} CACHE STRING "")
++ mark_as_advanced(PROTOBUF_PROTOC_LIBRARY)
+ endif()
+ endif()
+
+
+From f372ef83b99bf2dc2f4a456ab74c7831c347ec89 Mon Sep 17 00:00:00 2001
+From: Silvio Traversaro <silvio@traversaro.it>
+Date: Wed, 7 Jun 2023 00:39:40 +0200
+Subject: [PATCH 5/6] Update SearchForStuff.cmake
+
+---
+ cmake/SearchForStuff.cmake | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/cmake/SearchForStuff.cmake b/cmake/SearchForStuff.cmake
+index 1bbadd3c29..c400bee0e3 100644
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -65,10 +65,8 @@ else()
+ find_package(Protobuf CONFIG REQUIRED)
+ set (GZ_PROTOBUF_LIBRARY protobuf::libprotobuf)
+ set (GZ_PROTOBUF_PROTOC_LIBRARY protobuf::libprotoc)
+- if(NOT DEFINED PROTOBUF_PROTOC_LIBRARY)
+- get_target_property(PROTOBUF_PROTOC_LIBRARY_VAR protobuf::protoc LOCATION)
+- set(PROTOBUF_PROTOC_LIBRARY ${PROTOBUF_PROTOC_LIBRARY_VAR} CACHE STRING "")
+- mark_as_advanced(PROTOBUF_PROTOC_LIBRARY)
++ if(NOT DEFINED PROTOBUF_PROTOC_EXECUTABLE)
++ get_target_property(PROTOBUF_PROTOC_EXECUTABLE protobuf::protoc LOCATION)
+ endif()
+ endif()
+
+
+From c4674eee1ad234d4a74bafc1d3ec401b595d3d63 Mon Sep 17 00:00:00 2001
+From: Steve Peters <computersthatmove@gmail.com>
+Date: Wed, 14 Jun 2023 09:27:16 -0700
+Subject: [PATCH 6/6] Fix whitespace
+
+Signed-off-by: Steve Peters <scpeters@openrobotics.org>
+---
+ cmake/SearchForStuff.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/SearchForStuff.cmake b/cmake/SearchForStuff.cmake
+index c400bee0e3..948cf0a8a1 100644
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -32,7 +32,7 @@ endif()
+ ########################################
+ # The Google Protobuf library for message generation + serialization
+
+-# Protobuf >= 22 requires to link abseil, so we are constrained to use
++# Protobuf >= 22 requires to link abseil, so we are constrained to use
+ # find_package(Protobuf) and link to protobuf::libprotobuf,
+ # see https://github.com/conda-forge/conda-forge-pinning-feedstock/issues/4075#issuecomment-1569242816
+ if (DEFINED PROTOBUF_VERSION AND PROTOBUF_VERSION GREATER_EQUAL 22.0)
diff --git a/sci-electronics/gazebo/files/qwt.patch b/sci-electronics/gazebo/files/qwt.patch
deleted file mode 100644
index d4f1538900bc..000000000000
--- a/sci-electronics/gazebo/files/qwt.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: gazebo-8.0.0/cmake/SearchForStuff.cmake
-===================================================================
---- gazebo-8.0.0.orig/cmake/SearchForStuff.cmake
-+++ gazebo-8.0.0/cmake/SearchForStuff.cmake
-@@ -758,10 +758,10 @@ find_path(QWT_INCLUDE_DIR NAMES qwt.h PA
- /usr/local/lib/qwt.framework/Headers
- ${QWT_WIN_INCLUDE_DIR}
-
-- PATH_SUFFIXES qwt qwt5
-+ PATH_SUFFIXES qwt6
- )
-
--find_library(QWT_LIBRARY NAMES qwt-qt5 qwt PATHS
-+find_library(QWT_LIBRARY NAMES qwt6-qt5 qwt PATHS
- /usr/lib
- /usr/local/lib
- /usr/local/lib/qwt.framework
diff --git a/sci-electronics/gazebo/files/qwt2.patch b/sci-electronics/gazebo/files/qwt2.patch
new file mode 100644
index 000000000000..08e406055970
--- /dev/null
+++ b/sci-electronics/gazebo/files/qwt2.patch
@@ -0,0 +1,17 @@
+Index: gazebo-11.10.2/cmake/SearchForStuff.cmake
+===================================================================
+--- gazebo-11.10.2.orig/cmake/SearchForStuff.cmake
++++ gazebo-11.10.2/cmake/SearchForStuff.cmake
+@@ -847,10 +847,10 @@ find_path(QWT_INCLUDE_DIR NAMES qwt.h PA
+ /usr/local/lib/qwt.framework/Headers
+ ${QWT_WIN_INCLUDE_DIR}
+
+- PATH_SUFFIXES qwt qwt5
++ PATH_SUFFIXES qwt qwt5 qwt6
+ )
+
+-find_library(QWT_LIBRARY NAMES qwt-qt5 qwt PATHS
++find_library(QWT_LIBRARY NAMES qwt6-qt5 qwt-qt5 qwt PATHS
+ /usr/local/lib
+ /usr/local/lib/qwt.framework
+ ${QWT_WIN_LIBRARY_DIR}
diff --git a/sci-electronics/gazebo/gazebo-11.5.1-r3.ebuild b/sci-electronics/gazebo/gazebo-11.13.0.ebuild
index dd11acd611ae..801fdd8a98a1 100644
--- a/sci-electronics/gazebo/gazebo-11.5.1-r3.ebuild
+++ b/sci-electronics/gazebo/gazebo-11.13.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake flag-o-matic
+inherit cmake
DESCRIPTION="A 3D multiple robot simulator with dynamics"
-HOMEPAGE="http://gazebosim.org/"
+HOMEPAGE="https://gazebosim.org/home"
SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
LICENSE="Apache-2.0"
@@ -24,7 +24,7 @@ RDEPEND="
dev-libs/tinyxml
>=dev-libs/tinyxml2-6:=
dev-libs/libtar
- <dev-cpp/tbb-2021:=
+ dev-cpp/tbb:=
>=dev-games/ogre-1.7.4:=[freeimage]
<dev-games/ogre-1.10
>=media-libs/freeimage-3.15.4[png]
@@ -32,18 +32,18 @@ RDEPEND="
>=media-video/ffmpeg-2.6:0=
sci-libs/gts
>=sci-physics/bullet-2.82:=
- >=dev-libs/sdformat-9.1:=
+ >=dev-libs/sdformat-9.8:=
dev-qt/qtwidgets:5
dev-qt/qtcore:5
dev-qt/qtopengl:5
- dev-libs/boost:=[threads(+)]
+ dev-libs/boost:=
sci-libs/gdal:=
virtual/libusb:1
dev-libs/libspnav
media-libs/freeimage
sci-libs/hdf5:=[cxx]
sys-apps/util-linux
- media-gfx/graphviz
+ >=media-gfx/graphviz-4
net-libs/ignition-msgs:5=
sci-libs/ignition-math:6=
net-libs/ignition-transport:8=
@@ -57,14 +57,15 @@ DEPEND="${RDEPEND}
test? ( dev-libs/libxslt )
"
BDEPEND="
- app-text/ronn
+ app-text/ronn-ng
app-arch/gzip
virtual/pkgconfig
"
CMAKE_BUILD_TYPE=RelWithDebInfo
PATCHES=(
- "${FILESDIR}/qwt.patch"
+ "${FILESDIR}/qwt2.patch"
"${FILESDIR}/cmake.patch"
+ "${FILESDIR}/protobuf.patch"
)
src_configure() {
diff --git a/sci-electronics/gazebo/gazebo-11.3.0-r3.ebuild b/sci-electronics/gazebo/gazebo-11.14.0.ebuild
index dd11acd611ae..1746085d2235 100644
--- a/sci-electronics/gazebo/gazebo-11.3.0-r3.ebuild
+++ b/sci-electronics/gazebo/gazebo-11.14.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake flag-o-matic
+inherit cmake
DESCRIPTION="A 3D multiple robot simulator with dynamics"
-HOMEPAGE="http://gazebosim.org/"
+HOMEPAGE="https://gazebosim.org/home"
SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
LICENSE="Apache-2.0"
@@ -24,7 +24,7 @@ RDEPEND="
dev-libs/tinyxml
>=dev-libs/tinyxml2-6:=
dev-libs/libtar
- <dev-cpp/tbb-2021:=
+ dev-cpp/tbb:=
>=dev-games/ogre-1.7.4:=[freeimage]
<dev-games/ogre-1.10
>=media-libs/freeimage-3.15.4[png]
@@ -32,18 +32,18 @@ RDEPEND="
>=media-video/ffmpeg-2.6:0=
sci-libs/gts
>=sci-physics/bullet-2.82:=
- >=dev-libs/sdformat-9.1:=
+ >=dev-libs/sdformat-9.8:=
dev-qt/qtwidgets:5
dev-qt/qtcore:5
dev-qt/qtopengl:5
- dev-libs/boost:=[threads(+)]
+ dev-libs/boost:=
sci-libs/gdal:=
virtual/libusb:1
dev-libs/libspnav
media-libs/freeimage
sci-libs/hdf5:=[cxx]
sys-apps/util-linux
- media-gfx/graphviz
+ >=media-gfx/graphviz-4
net-libs/ignition-msgs:5=
sci-libs/ignition-math:6=
net-libs/ignition-transport:8=
@@ -57,14 +57,15 @@ DEPEND="${RDEPEND}
test? ( dev-libs/libxslt )
"
BDEPEND="
- app-text/ronn
+ app-text/ronn-ng
app-arch/gzip
virtual/pkgconfig
"
CMAKE_BUILD_TYPE=RelWithDebInfo
PATCHES=(
- "${FILESDIR}/qwt.patch"
+ "${FILESDIR}/qwt2.patch"
"${FILESDIR}/cmake.patch"
+ "${FILESDIR}/gv10.patch"
)
src_configure() {
diff --git a/sci-electronics/gazebo/gazebo-11.7.0-r2.ebuild b/sci-electronics/gazebo/gazebo-11.7.0-r2.ebuild
deleted file mode 100644
index dd11acd611ae..000000000000
--- a/sci-electronics/gazebo/gazebo-11.7.0-r2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="A 3D multiple robot simulator with dynamics"
-HOMEPAGE="http://gazebosim.org/"
-SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-# Subslot = major version = soname of libs
-SLOT="0/11"
-KEYWORDS="~amd64"
-IUSE="cpu_flags_x86_sse2 test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/protobuf-2:=
- virtual/opengl
- media-libs/openal
- net-misc/curl
- dev-libs/tinyxml
- >=dev-libs/tinyxml2-6:=
- dev-libs/libtar
- <dev-cpp/tbb-2021:=
- >=dev-games/ogre-1.7.4:=[freeimage]
- <dev-games/ogre-1.10
- >=media-libs/freeimage-3.15.4[png]
- sci-libs/libccd
- >=media-video/ffmpeg-2.6:0=
- sci-libs/gts
- >=sci-physics/bullet-2.82:=
- >=dev-libs/sdformat-9.1:=
- dev-qt/qtwidgets:5
- dev-qt/qtcore:5
- dev-qt/qtopengl:5
- dev-libs/boost:=[threads(+)]
- sci-libs/gdal:=
- virtual/libusb:1
- dev-libs/libspnav
- media-libs/freeimage
- sci-libs/hdf5:=[cxx]
- sys-apps/util-linux
- media-gfx/graphviz
- net-libs/ignition-msgs:5=
- sci-libs/ignition-math:6=
- net-libs/ignition-transport:8=
- sci-libs/ignition-common:3=
- sci-libs/ignition-fuel-tools:4=
- x11-libs/qwt:6=[qt5(+)]
-"
-DEPEND="${RDEPEND}
- dev-qt/qttest:5
- x11-apps/mesa-progs
- test? ( dev-libs/libxslt )
-"
-BDEPEND="
- app-text/ronn
- app-arch/gzip
- virtual/pkgconfig
-"
-CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=(
- "${FILESDIR}/qwt.patch"
- "${FILESDIR}/cmake.patch"
-)
-
-src_configure() {
- # find OGRE properly
- sed -e "s#lib/OGRE#$(get_libdir)/OGRE#" -i cmake/gazebo-config.cmake.in || die
-
- local mycmakeargs=(
- "-DUSE_UPSTREAM_CFLAGS=OFF"
- "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
- "-DUSE_HOST_CFLAGS=FALSE"
- "-DBUILD_TESTING=$(usex test TRUE FALSE)"
- "-DENABLE_SCREEN_TESTS=FALSE"
- "-DUSE_EXTERNAL_TINYXML2=TRUE"
- )
- cmake_src_configure
-}
diff --git a/sci-electronics/gazebo/gazebo-11.9.1.ebuild b/sci-electronics/gazebo/gazebo-11.9.1.ebuild
deleted file mode 100644
index c6602d9de1c3..000000000000
--- a/sci-electronics/gazebo/gazebo-11.9.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="A 3D multiple robot simulator with dynamics"
-HOMEPAGE="http://gazebosim.org/"
-SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-# Subslot = major version = soname of libs
-SLOT="0/11"
-KEYWORDS="~amd64"
-IUSE="cpu_flags_x86_sse2 test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/protobuf-2:=
- virtual/opengl
- media-libs/openal
- net-misc/curl
- dev-libs/tinyxml
- >=dev-libs/tinyxml2-6:=
- dev-libs/libtar
- <dev-cpp/tbb-2021:=
- >=dev-games/ogre-1.7.4:=[freeimage]
- <dev-games/ogre-1.10
- >=media-libs/freeimage-3.15.4[png]
- sci-libs/libccd
- >=media-video/ffmpeg-2.6:0=
- sci-libs/gts
- >=sci-physics/bullet-2.82:=
- >=dev-libs/sdformat-9.1:=
- dev-qt/qtwidgets:5
- dev-qt/qtcore:5
- dev-qt/qtopengl:5
- dev-libs/boost:=[threads(+)]
- sci-libs/gdal:=
- virtual/libusb:1
- dev-libs/libspnav
- media-libs/freeimage
- sci-libs/hdf5:=[cxx]
- sys-apps/util-linux
- media-gfx/graphviz
- net-libs/ignition-msgs:5=
- sci-libs/ignition-math:6=
- net-libs/ignition-transport:8=
- sci-libs/ignition-common:3=
- sci-libs/ignition-fuel-tools:4=
- <x11-libs/qwt-6.2.0:6=[qt5(+)]
-"
-DEPEND="${RDEPEND}
- dev-qt/qttest:5
- x11-apps/mesa-progs
- test? ( dev-libs/libxslt )
-"
-BDEPEND="
- app-text/ronn
- app-arch/gzip
- virtual/pkgconfig
-"
-CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=(
- "${FILESDIR}/qwt.patch"
- "${FILESDIR}/cmake.patch"
-)
-
-src_configure() {
- # find OGRE properly
- sed -e "s#lib/OGRE#$(get_libdir)/OGRE#" -i cmake/gazebo-config.cmake.in || die
-
- local mycmakeargs=(
- "-DUSE_UPSTREAM_CFLAGS=OFF"
- "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
- "-DUSE_HOST_CFLAGS=FALSE"
- "-DBUILD_TESTING=$(usex test TRUE FALSE)"
- "-DENABLE_SCREEN_TESTS=FALSE"
- "-DUSE_EXTERNAL_TINYXML2=TRUE"
- )
- cmake_src_configure
-}