summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gazebo')
-rw-r--r--sci-electronics/gazebo/files/qtmoc.patch44
-rw-r--r--sci-electronics/gazebo/gazebo-10.1.0.ebuild4
2 files changed, 46 insertions, 2 deletions
diff --git a/sci-electronics/gazebo/files/qtmoc.patch b/sci-electronics/gazebo/files/qtmoc.patch
new file mode 100644
index 000000000000..47841eb26e0d
--- /dev/null
+++ b/sci-electronics/gazebo/files/qtmoc.patch
@@ -0,0 +1,44 @@
+From 66dcba0375357d294d4769a6eb542de29b78a519 Mon Sep 17 00:00:00 2001
+From: Steve Peters <scpeters@openrobotics.org>
+Date: Thu, 26 Dec 2019 05:12:08 -0800
+Subject: [PATCH] use ifndef Q_MOC_RUN to fix compilation of plugins with tbb
+ and qt 5.14 (issue #2681)
+
+---
+ plugins/CessnaGUIPlugin.hh | 3 +++
+ plugins/LookAtDemoPlugin.hh | 3 +++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/plugins/CessnaGUIPlugin.hh b/plugins/CessnaGUIPlugin.hh
+index 7556d89982..091b8ffd00 100644
+--- a/plugins/CessnaGUIPlugin.hh
++++ b/plugins/CessnaGUIPlugin.hh
+@@ -23,7 +23,10 @@
+
+ #include <gazebo/common/Plugin.hh>
+ #include <gazebo/gui/GuiPlugin.hh>
++// moc parsing error of tbb headers
++#ifndef Q_MOC_RUN
+ #include <gazebo/transport/transport.hh>
++#endif
+
+ namespace gazebo
+ {
+diff --git a/plugins/LookAtDemoPlugin.hh b/plugins/LookAtDemoPlugin.hh
+index 5659394892..2a22b222f5 100644
+--- a/plugins/LookAtDemoPlugin.hh
++++ b/plugins/LookAtDemoPlugin.hh
+@@ -21,7 +21,10 @@
+
+ #include <gazebo/common/Plugin.hh>
+ #include <gazebo/gui/GuiPlugin.hh>
++// moc parsing error of tbb headers
++#ifndef Q_MOC_RUN
+ #include <gazebo/transport/transport.hh>
++#endif
+
+ namespace gazebo
+ {
+--
+2.24.1
+
diff --git a/sci-electronics/gazebo/gazebo-10.1.0.ebuild b/sci-electronics/gazebo/gazebo-10.1.0.ebuild
index 80c4d00fc21e..7b7aa2a408f5 100644
--- a/sci-electronics/gazebo/gazebo-10.1.0.ebuild
+++ b/sci-electronics/gazebo/gazebo-10.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -59,7 +59,7 @@ DEPEND="${RDEPEND}
test? ( dev-libs/libxslt )
"
CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=( "${FILESDIR}/qwt.patch" "${FILESDIR}/oal.patch" )
+PATCHES=( "${FILESDIR}/qwt.patch" "${FILESDIR}/oal.patch" "${FILESDIR}/qtmoc.patch" )
src_configure() {
# doesnt build without it