summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/geda/geda-1.9.2-r1.ebuild')
-rw-r--r--sci-electronics/geda/geda-1.9.2-r1.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/sci-electronics/geda/geda-1.9.2-r1.ebuild b/sci-electronics/geda/geda-1.9.2-r1.ebuild
index 2a44a907ab44..08129958fc60 100644
--- a/sci-electronics/geda/geda-1.9.2-r1.ebuild
+++ b/sci-electronics/geda/geda-1.9.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -52,6 +52,19 @@ src_prepare() {
sed -i -e 's/\texamples$//' Makefile.in || die
fi
+ # add missing GIO_LIB Bug #684870
+ sed -i -e 's/gsymcheck_LDFLAGS =/gsymcheck_LDFLAGS = $(GIO_LIBS)/' \
+ gsymcheck/src/Makefile.am || die
+
+ sed -i -e 's/gnetlist_LDFLAGS =/gnetlist_LDFLAGS = $(GIO_LIBS)/' \
+ gnetlist/src/Makefile.am || die
+
+ sed -i -e 's/gschlas_LDFLAGS =/gschlas_LDFLAGS = $(GIO_LIBS)/' \
+ utils/gschlas/Makefile.am || die
+
+ sed -i -e 's/sarlacc_schem_LDFLAGS =/sarlacc_schem_LDFLAGS = $(GIO_LIBS)/' \
+ contrib/sarlacc_schem/Makefile.am || die
+
eautoreconf
}