summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gwave/gwave-20190116.ebuild')
-rw-r--r--sci-electronics/gwave/gwave-20190116.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-electronics/gwave/gwave-20190116.ebuild b/sci-electronics/gwave/gwave-20190116.ebuild
new file mode 100644
index 000000000000..b82fb8c73281
--- /dev/null
+++ b/sci-electronics/gwave/gwave-20190116.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop gnome2-utils xdg-utils
+
+DESCRIPTION="Analog waveform viewer for SPICE-like simulations"
+HOMEPAGE="http://gwave.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/gwave3/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnuplot plotutils"
+SLOT="0"
+
+DEPEND="
+ >=dev-scheme/guile-2[networking]
+ >=x11-libs/gtk+-2.8.0:2=
+ sys-libs/readline:0=
+ sys-libs/ncurses:0="
+
+RDEPEND="${DEPEND}
+ sci-electronics/electronics-menu
+ gnuplot? ( sci-visualization/gnuplot )
+ plotutils? ( media-libs/plotutils )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-multiple-little-bugfixes.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-fix-configure.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon icons/wave-drag-ok.xpm gwave.xpm
+ make_desktop_entry gwave "Gwave" gwave "Electronics"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}