summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/klayout')
-rw-r--r--sci-electronics/klayout/Manifest3
-rw-r--r--sci-electronics/klayout/klayout-0.27.10.ebuild91
-rw-r--r--sci-electronics/klayout/klayout-0.28.9.ebuild (renamed from sci-electronics/klayout/klayout-0.27.7.ebuild)8
-rw-r--r--sci-electronics/klayout/klayout-9999.ebuild8
-rw-r--r--sci-electronics/klayout/metadata.xml3
5 files changed, 12 insertions, 101 deletions
diff --git a/sci-electronics/klayout/Manifest b/sci-electronics/klayout/Manifest
index 5af88e78120a..328e9c04e415 100644
--- a/sci-electronics/klayout/Manifest
+++ b/sci-electronics/klayout/Manifest
@@ -1,2 +1 @@
-DIST klayout-0.27.10.tar.gz 57428098 BLAKE2B 3f64ed6a65ec7d2732691594f50d02f160725a3306cd0d0593f8c2b5978d5cf76e004ed3347bb6e9d9473b8e0974bc04de101ec3bf168faf147e6c64c5f0bdcb SHA512 a637b0a0bd1eaa3c858c333791c5592bc8a4dc1db7413b83432d7bedce9ba7e1210c76086a4f39504bc23a11778a45370b86262c88daa579517e1dee940ecda7
-DIST klayout-0.27.7.tar.gz 57348398 BLAKE2B c717d1041e2b2f1ec4835db3861a8c7ff15d2cd703d3424d9219cb0fab06471a6838503c882b841be45c9e1b9280d1f7a099f9824c6e286940d3b44713927974 SHA512 f4b4f3f2216307df5dca3b9c9c4eee5b45e5811a3307f36d3ad759d33beb8cd83880485284492583b891ee8bbf2866cae0ce87b5c5971478d8ad8daad315bb09
+DIST klayout-0.28.9.tar.gz 88388706 BLAKE2B 0997bf15aae1dd1e8356fec91ae281511751db0ae1a4bfdfde38d5a04392351a7893206806a0eb7d842f8ee2fd7819b1a86257376d3ba5af11bb81b84836e571 SHA512 dcd882ef84161f2d28195f8e0239fd122f17f9954e5cc146f71bbb6816b9fb723eb3b0299e01fbb293ef7fb7f87c25efbfe09126349ee13f89de68c5bb5f7e93
diff --git a/sci-electronics/klayout/klayout-0.27.10.ebuild b/sci-electronics/klayout/klayout-0.27.10.ebuild
deleted file mode 100644
index 75368510a1f8..000000000000
--- a/sci-electronics/klayout/klayout-0.27.10.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-RUBY_OPTIONAL=no
-USE_RUBY="ruby27"
-# note: define maximally ONE implementation here
-
-PYTHON_COMPAT=( python3_{8,9,10,11} )
-
-inherit toolchain-funcs python-single-r1 ruby-ng
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/klayoutmatthias/${PN}.git"
- inherit git-r3
- EGIT_CHECKOUT_DIR=${WORKDIR}/all/${P}
-else
- SRC_URI="https://www.klayout.org/downloads/source/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
-HOMEPAGE="https://www.klayout.de/"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND="
- dev-qt/designer:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5[widgets]
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtprintsupport:5
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qttest:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- dev-qt/qtxmlpatterns:5
- sys-libs/zlib
- ${PYTHON_DEPS}
- $(ruby_implementations_depend)
-"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- python-single-r1_pkg_setup
- ruby-ng_pkg_setup
-}
-
-each_ruby_configure() {
- tc-export CC CXX AR LD RANLIB
- export CFLAGS CXXFLAGS
- ./build.sh \
- -expert \
- -dry-run \
- -qmake "$EPREFIX/usr/$(get_libdir)/qt5/bin/qmake" \
- -ruby "${RUBY}" \
- -python "${PYTHON}" \
- -build . \
- -bin "${T}/bin" \
- -rpath "$EPREFIX/usr/$(get_libdir)/klayout" \
- -option "${MAKEOPTS}" \
- -with-qtbinding \
- -without-64bit-coord \
- -qt5 || die "Configuration failed"
-}
-
-each_ruby_compile() {
- emake all
-}
-
-each_ruby_install() {
- emake install
-
- cd "${T}/bin" || die
-
- dodir "/usr/$(get_libdir)/klayout"
- mv lib* lay_plugins db_plugins "${ED}/usr/$(get_libdir)/klayout/" || die
-
- mkdir -p "${D}/$(python_get_sitedir)" || die
- mv pymod/* "${D}/$(python_get_sitedir)/" || die
- rmdir pymod || die
-
- dobin *
-
- python_optimize
-}
diff --git a/sci-electronics/klayout/klayout-0.27.7.ebuild b/sci-electronics/klayout/klayout-0.28.9.ebuild
index 36a5f7cd2663..a67a35ae96a7 100644
--- a/sci-electronics/klayout/klayout-0.27.7.ebuild
+++ b/sci-electronics/klayout/klayout-0.28.9.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
RUBY_OPTIONAL=no
-USE_RUBY="ruby27"
+USE_RUBY="ruby31"
# note: define maximally ONE implementation here
-PYTHON_COMPAT=( python3_{8,9,10,11} )
+PYTHON_COMPAT=( python3_{9,10,11,12} )
inherit toolchain-funcs python-single-r1 ruby-ng
diff --git a/sci-electronics/klayout/klayout-9999.ebuild b/sci-electronics/klayout/klayout-9999.ebuild
index 75368510a1f8..a09175915e24 100644
--- a/sci-electronics/klayout/klayout-9999.ebuild
+++ b/sci-electronics/klayout/klayout-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
RUBY_OPTIONAL=no
-USE_RUBY="ruby27"
+USE_RUBY="ruby31"
# note: define maximally ONE implementation here
-PYTHON_COMPAT=( python3_{8,9,10,11} )
+PYTHON_COMPAT=( python3_{9,10,11,12} )
inherit toolchain-funcs python-single-r1 ruby-ng
diff --git a/sci-electronics/klayout/metadata.xml b/sci-electronics/klayout/metadata.xml
index d05a4868cfa5..515e8491e641 100644
--- a/sci-electronics/klayout/metadata.xml
+++ b/sci-electronics/klayout/metadata.xml
@@ -9,4 +9,7 @@
<email>sci-electronics@gentoo.org</email>
<name>Gentoo Electronics Project</name>
</maintainer>
+<upstream>
+ <remote-id type="github">KLayout/klayout</remote-id>
+</upstream>
</pkgmetadata>