summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/ngspice/files')
-rw-r--r--sci-electronics/ngspice/files/ngspice-27-blt_linkage_workaround.patch12
-rw-r--r--sci-electronics/ngspice/files/ngspice-27-fix_parsing_tcl_commands.patch16
2 files changed, 28 insertions, 0 deletions
diff --git a/sci-electronics/ngspice/files/ngspice-27-blt_linkage_workaround.patch b/sci-electronics/ngspice/files/ngspice-27-blt_linkage_workaround.patch
new file mode 100644
index 000000000000..53415c748d6d
--- /dev/null
+++ b/sci-electronics/ngspice/files/ngspice-27-blt_linkage_workaround.patch
@@ -0,0 +1,12 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -461,6 +461,9 @@
+ AC_MSG_ERROR([Couldn't find BLT])
+ fi
+ rm -f conftest.tcl
++
++ AC_SEARCH_LIBS([Blt_GetVector], [BLT BLT24 BLT25],,
++ [AC_MSG_ERROR([Couldnt find BLT library.])])
+
+ AC_CHECK_LIB([pthread], [pthread_create])
+
diff --git a/sci-electronics/ngspice/files/ngspice-27-fix_parsing_tcl_commands.patch b/sci-electronics/ngspice/files/ngspice-27-fix_parsing_tcl_commands.patch
new file mode 100644
index 000000000000..bad336590dfa
--- /dev/null
+++ b/sci-electronics/ngspice/files/ngspice-27-fix_parsing_tcl_commands.patch
@@ -0,0 +1,16 @@
+--- a/src/tclspice.c
++++ b/src/tclspice.c
+@@ -828,10 +828,9 @@
+ int i;
+ NG_IGNORE(clientData);
+ save_interp();
+- /* Looks backwards through the first command and strips the :: part */
+- for (i = strlen(argv[0])-1; i > 0; i--)
+- if (argv[0][i] == *":")
+- argv[0] += i + 1;
++ char *prefix = strstr(argv[0], "spice::");
++ if (prefix)
++ argv[0] = prefix + 7;
+ return _run(argc, (char **)argv);
+ }
+