summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/osqoop/osqoop-1.1.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sci-electronics/osqoop/osqoop-1.1.1.ebuild b/sci-electronics/osqoop/osqoop-1.1.1.ebuild
index 3e01da3a58d7..4d309cd97345 100644
--- a/sci-electronics/osqoop/osqoop-1.1.1.ebuild
+++ b/sci-electronics/osqoop/osqoop-1.1.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils toolchain-funcs
@@ -22,6 +22,8 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}-${PN}
src_prepare() {
+ cmake-utils_src_prepare
+
for f in $(find datasource processing -name CMakeLists.txt); do
sed -e '/install(TARGETS/s:DESTINATION :DESTINATION '$(get_libdir)/${PN}'/:' \
-i "${f}" || die