summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gazebo/files/oal.patch19
-rw-r--r--sci-electronics/gazebo/gazebo-10.1.0.ebuild2
2 files changed, 20 insertions, 1 deletions
diff --git a/sci-electronics/gazebo/files/oal.patch b/sci-electronics/gazebo/files/oal.patch
new file mode 100644
index 000000000000..4a09793aed00
--- /dev/null
+++ b/sci-electronics/gazebo/files/oal.patch
@@ -0,0 +1,19 @@
+Fixes build with openal 1.20
+
+Index: gazebo-10.1.0/gazebo/util/OpenALPrivate.hh
+===================================================================
+--- gazebo-10.1.0.orig/gazebo/util/OpenALPrivate.hh
++++ gazebo-10.1.0/gazebo/util/OpenALPrivate.hh
+@@ -37,10 +37,10 @@ namespace gazebo
+ class OpenALPrivate
+ {
+ /// \brief OpenAL audio context pointer.
+- public: ALCcontext_struct *context;
++ public: ALCcontext *context;
+
+ /// \brief OpenAL audio device pointer.
+- public: ALCdevice_struct *audioDevice;
++ public: ALCdevice *audioDevice;
+
+ /// \brief OpenAL sink pointer.
+ public: OpenALSinkPtr sink;
diff --git a/sci-electronics/gazebo/gazebo-10.1.0.ebuild b/sci-electronics/gazebo/gazebo-10.1.0.ebuild
index 2ba6f5bb35d4..dbc0c2f89e3d 100644
--- a/sci-electronics/gazebo/gazebo-10.1.0.ebuild
+++ b/sci-electronics/gazebo/gazebo-10.1.0.ebuild
@@ -58,7 +58,7 @@ DEPEND="${RDEPEND}
test? ( dev-libs/libxslt )
"
CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=( "${FILESDIR}/qwt.patch" )
+PATCHES=( "${FILESDIR}/qwt.patch" "${FILESDIR}/oal.patch" )
src_configure() {
# doesnt build without it