summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/opencpn-plugin-iacfleet')
-rw-r--r--sci-geosciences/opencpn-plugin-iacfleet/Manifest2
-rw-r--r--sci-geosciences/opencpn-plugin-iacfleet/metadata.xml2
-rw-r--r--sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-0.21.1-r1.ebuild43
-rw-r--r--sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-0.9.ebuild37
-rw-r--r--sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-9999.ebuild40
5 files changed, 68 insertions, 56 deletions
diff --git a/sci-geosciences/opencpn-plugin-iacfleet/Manifest b/sci-geosciences/opencpn-plugin-iacfleet/Manifest
index 34bf5ec959da..359143604f59 100644
--- a/sci-geosciences/opencpn-plugin-iacfleet/Manifest
+++ b/sci-geosciences/opencpn-plugin-iacfleet/Manifest
@@ -1 +1 @@
-DIST opencpn-plugin-iacfleet-0.9.tar.gz 218686 BLAKE2B 6c27fd57e7dc75d0a203a823ec75cacaf6fc351d58176f536542242b20e887ff58596bf114693d740258fd2c1a6af244f53825d0561ae9c396c5f556c0e1217a SHA512 f1e54fb17517dac2442de3bca85042add4a05f0b1caf144901581694403a9d9be9732a66f236f16014522b05108877b0dc530850bdf66b530e71c1b3cc010baf
+DIST opencpn-plugin-iacfleet-0.21.1.tar.gz 228102 BLAKE2B eedb536e954f4534c7e256800e8888ff9f7d9eac5b26e21013f7ff519dfa9826253fef9d1f09af265fc448662551a16fbf5e5ab1a21bf3aa75234a8e5d170ee4 SHA512 86e26ca2291d36bdf8090ff03a9d1a79c263549ba7f5db34ed3e47be14f73eec35319567b76e66e6e87a21a1486b71c77964545da6ceab896bb42965c484c78d
diff --git a/sci-geosciences/opencpn-plugin-iacfleet/metadata.xml b/sci-geosciences/opencpn-plugin-iacfleet/metadata.xml
index b55736430c4c..549efe21a11b 100644
--- a/sci-geosciences/opencpn-plugin-iacfleet/metadata.xml
+++ b/sci-geosciences/opencpn-plugin-iacfleet/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>mschiff@gentoo.org</email>
diff --git a/sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-0.21.1-r1.ebuild b/sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-0.21.1-r1.ebuild
new file mode 100644
index 000000000000..a21dc632da69
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-0.21.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit cmake flag-o-matic wxwidgets
+
+MY_PN="iacfleet_pi"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nohal/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="IAC Fleetcode Plugin for OpenCPN"
+HOMEPAGE="https://github.com/nohal/iacfleet_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ sci-geosciences/opencpn:="
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/927485
+ # https://github.com/nohal/iacfleet_pi/issues/30
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ setup-wxwidgets unicode
+ cmake_src_configure
+}
diff --git a/sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-0.9.ebuild b/sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-0.9.ebuild
deleted file mode 100644
index 6e2c14f2c4b4..000000000000
--- a/sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-0.9.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-WX_GTK_VER="3.0"
-MY_PN="iacfleet_pi"
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/nohal/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
- KEYWORDS=""
-else
- SRC_URI="
- https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
-
-DESCRIPTION="IAC Fleetcode Plugin for OpenCPN"
-HOMEPAGE="https://github.com/nohal/iacfleet_pi"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
-DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
-}
diff --git a/sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-9999.ebuild b/sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-9999.ebuild
index 6e2c14f2c4b4..a21dc632da69 100644
--- a/sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-9999.ebuild
+++ b/sci-geosciences/opencpn-plugin-iacfleet/opencpn-plugin-iacfleet-9999.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit cmake flag-o-matic wxwidgets
-WX_GTK_VER="3.0"
MY_PN="iacfleet_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/nohal/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
- KEYWORDS=""
else
- SRC_URI="
- https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -23,15 +22,22 @@ HOMEPAGE="https://github.com/nohal/iacfleet_pi"
LICENSE="GPL-2+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ sci-geosciences/opencpn:="
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/927485
+ # https://github.com/nohal/iacfleet_pi/issues/30
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ setup-wxwidgets unicode
+ cmake_src_configure
}