summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/opencpn-plugin-weatherfax')
-rw-r--r--sci-geosciences/opencpn-plugin-weatherfax/metadata.xml2
-rw-r--r--sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.20180316.ebuild30
-rw-r--r--sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild30
3 files changed, 29 insertions, 33 deletions
diff --git a/sci-geosciences/opencpn-plugin-weatherfax/metadata.xml b/sci-geosciences/opencpn-plugin-weatherfax/metadata.xml
index 876385098e23..cd6445f1b395 100644
--- a/sci-geosciences/opencpn-plugin-weatherfax/metadata.xml
+++ b/sci-geosciences/opencpn-plugin-weatherfax/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>mschiff@gentoo.org</email>
diff --git a/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.20180316.ebuild b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.20180316.ebuild
index a9bec2036741..b0cb5f6225f3 100644
--- a/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.20180316.ebuild
+++ b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.20180316.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
MY_PN="weatherfax_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
- KEYWORDS=""
else
- SRC_URI="
- https://github.com/mschiff/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/mschiff/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -23,15 +22,14 @@ HOMEPAGE="https://github.com/seandepagnier/weatherfax_pi"
LICENSE="GPL-3+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ >=sci-geosciences/opencpn-4.2.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
}
diff --git a/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild
index a9bec2036741..b0cb5f6225f3 100644
--- a/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild
+++ b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
MY_PN="weatherfax_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
- KEYWORDS=""
else
- SRC_URI="
- https://github.com/mschiff/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/mschiff/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -23,15 +22,14 @@ HOMEPAGE="https://github.com/seandepagnier/weatherfax_pi"
LICENSE="GPL-3+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ >=sci-geosciences/opencpn-4.2.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
}