summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qgis/metadata.xml1
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/sci-geosciences/qgis/metadata.xml b/sci-geosciences/qgis/metadata.xml
index 162cbbaa3dec..868a026b6c1e 100644
--- a/sci-geosciences/qgis/metadata.xml
+++ b/sci-geosciences/qgis/metadata.xml
@@ -18,6 +18,7 @@
<flag name="georeferencer">Determines whether georeferencer plugin should be built</flag>
<flag name="grass">Add support for <pkg>sci-geosciences/grass</pkg></flag>
<flag name="mapserver">Determines whether mapserver should be built</flag>
+ <flag name="opencl">Enable OpenCL support</flag>
<flag name="polar">Enable support for the polar coordinate system via <pkg>x11-libs/qwtpolar</pkg></flag>
<flag name="qml">Enable support Qml-based plugins using <pkg>dev-qt/qtdeclarative</pkg></flag>
</use>
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index e8cba614b61d..ab077fc720a4 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="https://www.qgis.org/"
LICENSE="GPL-2+ GPL-3+"
SLOT="0"
-IUSE="3d examples georeferencer grass mapserver oracle polar postgres python qml webkit"
+IUSE="3d examples georeferencer grass mapserver opencl oracle polar postgres python qml webkit"
REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
@@ -60,6 +60,7 @@ COMMON_DEPEND="
georeferencer? ( sci-libs/gsl:= )
grass? ( =sci-geosciences/grass-7*:= )
mapserver? ( dev-libs/fcgi )
+ opencl? ( virtual/opencl )
oracle? (
dev-db/oracle-instantclient:=
sci-libs/gdal:=[oracle]
@@ -131,6 +132,7 @@ src_configure() {
-DWITH_GEOREFERENCER=$(usex georeferencer)
-DWITH_GRASS7=$(usex grass)
-DWITH_SERVER=$(usex mapserver)
+ -DUSE_OPENCL=$(usex opencl)
-DWITH_ORACLE=$(usex oracle)
-DWITH_QWTPOLAR=$(usex polar)
-DWITH_POSTGRESQL=$(usex postgres)