summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/amd/amd-2.3.1.ebuild')
-rw-r--r--sci-libs/amd/amd-2.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/amd/amd-2.3.1.ebuild b/sci-libs/amd/amd-2.3.1.ebuild
new file mode 100644
index 000000000000..a68446a9c763
--- /dev/null
+++ b/sci-libs/amd/amd-2.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils fortran-2
+
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/amd"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc fortran static-libs"
+
+RDEPEND="sci-libs/suitesparseconfig"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable fortran)
+ $(use_with doc)
+ )
+ autotools-utils_src_configure
+}