summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/camd/files/camd-2.2.0-autotools.patch')
-rw-r--r--sci-libs/camd/files/camd-2.2.0-autotools.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/sci-libs/camd/files/camd-2.2.0-autotools.patch b/sci-libs/camd/files/camd-2.2.0-autotools.patch
new file mode 100644
index 000000000000..d112a5f17169
--- /dev/null
+++ b/sci-libs/camd/files/camd-2.2.0-autotools.patch
@@ -0,0 +1,71 @@
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-31 15:35:15.579030692 +0000
+@@ -0,0 +1,12 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(camd, 2.2.0, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADERS(UFconfig.h)
++AC_CONFIG_FILES([Source/Makefile
++ Demo/Makefile
++ Makefile])
++AC_OUTPUT
+--- ./Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ ./Demo/Makefile.am 2008-01-31 15:36:57.492838429 +0000
+@@ -0,0 +1,27 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++check_PROGRAMS = \
++ camd_demo \
++ camd_demo2 \
++ camd_simple
++# test is not robust
++# camd_l_demo
++
++LDADD = $(top_builddir)/Source/libcamd.la -lm
++
++camd_demo_SOURCES = camd_demo.c
++#camd_l_demo_SOURCES = camd_l_demo.c
++camd_demo2_SOURCES = camd_demo2.c
++camd_simple_SOURCES = camd_simple.c
++
++check-local: $(check_PROGRAMS)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i > my_$$i.out; \
++ if ! diff $(srcdir)/$$i.out my_$$i.out; then \
++ echo "Test $$i failed!"; \
++ exit 1; \
++ fi \
++ done;
++
++clean-local:
++ rm -f my*.out
+--- ./Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ ./Source/Makefile.am 2008-01-31 15:37:17.205961816 +0000
+@@ -0,0 +1,17 @@
++CAMDCSRC = \
++ camd_aat.c camd_1.c camd_2.c camd_dump.c camd_postorder.c \
++ camd_defaults.c camd_order.c camd_control.c camd_info.c \
++ camd_valid.c camd_preprocess.c
++
++lib_LTLIBRARIES = libcamd.la
++noinst_LTLIBRARIES = libcamdi.la libcamdl.la
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++libcamdi_la_SOURCES = $(CAMDCSRC)
++libcamdi_la_CPPFLAGS = $(AM_CPPFLAGS) -DDINT
++libcamdl_la_SOURCES = $(CAMDCSRC)
++libcamdl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++libcamd_la_SOURCES = camd_global.c
++libcamd_la_LIBADD = libcamdl.la libcamdi.la -lm
++
+--- ./Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ ./Makefile.am 2008-01-31 15:34:59.202097424 +0000
+@@ -0,0 +1,3 @@
++SUBDIRS = Demo Source
++EXTRA_DIST = README.txt
++include_HEADERS = Include/camd.h Include/camd_internal.h