summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/fcl/fcl-0.4.0.ebuild')
-rw-r--r--sci-libs/fcl/fcl-0.4.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/fcl/fcl-0.4.0.ebuild b/sci-libs/fcl/fcl-0.4.0.ebuild
new file mode 100644
index 000000000000..064b54f963d4
--- /dev/null
+++ b/sci-libs/fcl/fcl-0.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/flexible-collision-library/fcl"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/flexible-collision-library/fcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="The Flexible Collision Library"
+HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="cpu_flags_x86_sse"
+
+RDEPEND="
+ sci-libs/octomap
+ sci-libs/flann
+ dev-libs/boost:=[threads]
+ sci-libs/libccd"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
+ )
+ cmake-utils_src_configure
+}