summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-19 13:50:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-19 13:50:19 +0100
commit82aecb580395c02c8f5411906452a4f01684165b (patch)
treeed300079730a4de736960ae18d90d8d30bb1bc2e /sci-libs/fcl/fcl-0.4.0.ebuild
parentdev-ml/eliom: backport upstream patch to build with tyxml 3.6 (diff)
downloadgentoo-82aecb580395c02c8f5411906452a4f01684165b.tar.gz
gentoo-82aecb580395c02c8f5411906452a4f01684165b.tar.bz2
gentoo-82aecb580395c02c8f5411906452a4f01684165b.zip
sci-libs/fcl: bump to 0.4.0
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-libs/fcl/fcl-0.4.0.ebuild')
-rw-r--r--sci-libs/fcl/fcl-0.4.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/fcl/fcl-0.4.0.ebuild b/sci-libs/fcl/fcl-0.4.0.ebuild
new file mode 100644
index 000000000000..064b54f963d4
--- /dev/null
+++ b/sci-libs/fcl/fcl-0.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/flexible-collision-library/fcl"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/flexible-collision-library/fcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="The Flexible Collision Library"
+HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="cpu_flags_x86_sse"
+
+RDEPEND="
+ sci-libs/octomap
+ sci-libs/flann
+ dev-libs/boost:=[threads]
+ sci-libs/libccd"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
+ )
+ cmake-utils_src_configure
+}