summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gts/gts-20121130.ebuild')
-rw-r--r--sci-libs/gts/gts-20121130.ebuild61
1 files changed, 37 insertions, 24 deletions
diff --git a/sci-libs/gts/gts-20121130.ebuild b/sci-libs/gts/gts-20121130.ebuild
index 2a29d95b7edf..2ce0a8b48a5e 100644
--- a/sci-libs/gts/gts-20121130.ebuild
+++ b/sci-libs/gts/gts-20121130.ebuild
@@ -1,49 +1,62 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
+inherit autotools
-inherit autotools-utils
-
-MYP=${P/-20/-snapshot-}
+MY_P=${P/-20/-snapshot-}
DESCRIPTION="GNU Triangulated Surface Library"
HOMEPAGE="http://gts.sourceforge.net/"
-SRC_URI="http://gts.sourceforge.net/tarballs/${MYP}.tar.gz"
+SRC_URI="http://gts.sourceforge.net/tarballs/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
-SLOT="0"
LICENSE="LGPL-2"
+SLOT="0"
KEYWORDS="amd64 ~arm64 hppa ~mips ppc ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs test"
+IUSE="doc test"
+RESTRICT="test" # bug #277165
RDEPEND="dev-libs/glib:2"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
doc? ( dev-util/gtk-doc )
test? ( media-libs/netpbm )"
-# buggy
-RESTRICT=test
+PATCHES=( "${FILESDIR}"/${PN}-20121130-autotools.patch )
+
+src_prepare() {
+ default
-S="${WORKDIR}/${MYP}"
+ # fix doc generation (bug #727536)
+ sed -i 's/\xe9/\xc3\xa9/;s/\xf6/\xc3\xb6/' src/*.{c,h} || die
-AUTOTOOLS_IN_SOURCE_BUILD=1
+ # allow to run tests (bug #277165)
+ chmod +x test/*/*.sh || die
+
+ eautoreconf
+}
-PATCHES=( "${FILESDIR}"/${PN}-20111025-autotools.patch )
+src_configure() {
+ econf --disable-static
+}
src_compile() {
- autotools-utils_src_compile
- use doc && autotools-utils_src_compile -C doc html
- chmod +x test/*/*.sh || die
+ default
+
+ if use doc; then
+ emake DOC_MAIN_SGML_FILE=gts-docs.xml -C doc html
+ HTML_DOCS=( doc/html/. )
+ fi
}
src_install() {
- use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}"/doc/html/)
- autotools-utils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.c
- fi
+ default
+
+ docinto examples
+ dodoc examples/*.c
+
+ find "${ED}" -name '*.la' -delete || die
}