summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libspatialindex/libspatialindex-1.8.3.ebuild')
-rw-r--r--sci-libs/libspatialindex/libspatialindex-1.8.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/libspatialindex/libspatialindex-1.8.3.ebuild b/sci-libs/libspatialindex/libspatialindex-1.8.3.ebuild
new file mode 100644
index 000000000000..2f14d7bd0d7e
--- /dev/null
+++ b/sci-libs/libspatialindex/libspatialindex-1.8.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_PN="spatialindex-src"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="General framework for developing spatial indices"
+HOMEPAGE="http://libspatialindex.github.com/"
+SRC_URI="http://download.osgeo.org/libspatialindex/${MY_P}.tar.bz2"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0/3"
+IUSE="debug static-libs"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.1-QA.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}