summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/mmtk/mmtk-2.7.5.ebuild')
-rw-r--r--sci-libs/mmtk/mmtk-2.7.5.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/mmtk/mmtk-2.7.5.ebuild b/sci-libs/mmtk/mmtk-2.7.5.ebuild
new file mode 100644
index 000000000000..f8128f575760
--- /dev/null
+++ b/sci-libs/mmtk/mmtk-2.7.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit distutils
+
+# This number identifies each release on the CRU website.
+# Can't figure out how to avoid hardcoding it.
+NUMBER="3794"
+
+MY_PN=${PN/mmtk/MMTK}
+MY_P=${MY_PN}-${PV}
+
+PYTHON_MODNAME="${MY_PN}"
+
+DESCRIPTION="Molecular Modeling ToolKit for Python"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/MMTK/"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${NUMBER}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~ppc ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cython
+ <dev-python/numpy-1.9
+ dev-python/scientificpython"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ export MMTK_USE_CYTHON="1"
+ sed -i -e "/ext_package/d" \
+ "${S}"/setup.py \
+ || die
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc README* Doc/CHANGELOG
+ dohtml -r Doc/HTML/*
+
+ if use examples; then
+ insinto /usr/share/${P}
+ doins -r Examples
+ fi
+}