summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/orocos-bfl')
-rw-r--r--sci-libs/orocos-bfl/Manifest1
-rw-r--r--sci-libs/orocos-bfl/metadata.xml14
-rw-r--r--sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild63
3 files changed, 78 insertions, 0 deletions
diff --git a/sci-libs/orocos-bfl/Manifest b/sci-libs/orocos-bfl/Manifest
new file mode 100644
index 000000000000..eede2eae1d91
--- /dev/null
+++ b/sci-libs/orocos-bfl/Manifest
@@ -0,0 +1 @@
+DIST orocos-bfl-0.8.0-src.tar.bz2 212899 SHA256 e5e14f8abbc4c38ca51f5ff97b36f66c69da3a706ee6276bcb151ada4c71195c SHA512 045bbc415feec66206774a8bdea3843a7edf233d221bd639b1dcc01906386ff55f114a9685e1008b741ae895e6aef33641a1eab67cb106d23a085d77f1a937d5 WHIRLPOOL ba5ff1ad0ff25cbc45367ed3d0bc1f356ef827f1b0ef6fa3e4c26a0a0da7ef8efc44bb6b0b1a33cbc068f28d079d0f9e096b14efd5df0d54d5dafe80e95c0fec
diff --git a/sci-libs/orocos-bfl/metadata.xml b/sci-libs/orocos-bfl/metadata.xml
new file mode 100644
index 000000000000..b187a8cfc9fa
--- /dev/null
+++ b/sci-libs/orocos-bfl/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>aballier@gentoo.org</email>
+<name>Alexis Ballier</name>
+</maintainer>
+<longdescription lang="en">
+ The Bayesian Filtering Library (BFL) provides an application independent framework
+ for inference in Dynamic Bayesian Networks, i.e., recursive information processing
+ and estimation algorithms based on Bayes' rule, such as (Extended) Kalman Filters,
+ Particle Filters (or Sequential Monte Carlo methods), etc.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild b/sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild
new file mode 100644
index 000000000000..d326f65c46db
--- /dev/null
+++ b/sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Bayesian Filtering Library"
+HOMEPAGE="http://orocos.org/bfl"
+SRC_URI="http://people.mech.kuleuven.be/~tdelaet/bfl_tar/${P}-src.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="doc examples static-libs test"
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ virtual/latex-base
+ )
+ test? ( dev-util/cppunit )"
+
+src_prepare() {
+ sed -e 's:/lib:/${CMAKE_INSTALL_LIBDIR}:' \
+ -i "${S}/"{,src/,src/bindings/rtt/}CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DLIBRARY_TYPE=$(usex static-libs both shared)"
+ "-DBUILD_EXAMPLES=$(usex examples ON OFF)"
+ "-DBUILD_TESTS=$(usex test ON OFF)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc ; then
+ cd "${BUILD_DIR}"
+ doxygen || die
+ cd "${S}/docs" || die
+ pdflatex getting_started_guide || die
+ pdflatex getting_started_guide || die
+ fi
+}
+
+src_test() {
+ cd "${BUILD_DIR}"
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc ; then
+ dohtml -r "${BUILD_DIR}/doc/html/"
+ dodoc "${S}/docs/getting_started_guide.pdf"
+ fi
+}