summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/proj')
-rw-r--r--sci-libs/proj/proj-7.0.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sci-libs/proj/proj-7.0.0.ebuild b/sci-libs/proj/proj-7.0.0.ebuild
index 1864512c1dcd..3f8a132182ff 100644
--- a/sci-libs/proj/proj-7.0.0.ebuild
+++ b/sci-libs/proj/proj-7.0.0.ebuild
@@ -18,9 +18,10 @@ LICENSE="MIT"
SLOT="0/19"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="europe static-libs test"
-RESTRICT="!test? ( test )"
REQUIRED_USE="test? ( !europe )"
+RESTRICT="!test? ( test )"
+
RDEPEND="dev-db/sqlite:3"
DEPEND="${RDEPEND}"
@@ -33,9 +34,7 @@ src_unpack() {
}
src_configure() {
- econf \
- $(use_enable static-libs static) \
- --without-jni
+ econf $(use_enable static-libs static)
}
src_install() {
@@ -43,5 +42,5 @@ src_install() {
cd data || die
dodoc README.{DATA,DATUMGRID}
use europe && dodoc README.EUROPE
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}