summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/qd')
-rw-r--r--sci-libs/qd/Manifest2
-rw-r--r--sci-libs/qd/files/qd-2.3.13-autotools.patch15
-rw-r--r--sci-libs/qd/metadata.xml10
-rw-r--r--sci-libs/qd/qd-2.3.13.ebuild37
-rw-r--r--sci-libs/qd/qd-2.3.14.ebuild37
5 files changed, 101 insertions, 0 deletions
diff --git a/sci-libs/qd/Manifest b/sci-libs/qd/Manifest
new file mode 100644
index 000000000000..8a18e445b98f
--- /dev/null
+++ b/sci-libs/qd/Manifest
@@ -0,0 +1,2 @@
+DIST qd-2.3.13.tar.gz 1449514 SHA256 578722fc515c54b4a2bd946d765412622139307cacb882e4b5ca2f314ed9c965 SHA512 40b1c400544e3c6306bec58b90561dec7781e80caa3e53eebd8a77933447d2f2aeb44599ff0bc19528452c7486f34bb3876e5d9581f4c9963692c99689f4451f WHIRLPOOL ff34ede9297c573a2d45b2108640c249cb9a0b6d26997363eb6cf43f2228eaebbe6f5623ad3bad9959c8c1be9d0eaf5eed881be713e375ab52fdfb49a4704f25
+DIST qd-2.3.14.tar.gz 1450068 SHA256 a9a5f85d20c246516484acf62b4514110fc8fd418594862e96859b5de9aed5d1 SHA512 1f79a4b7e8bec7f2576a79e4eec38e376fc075131248861ebb27d25746ca8ac4becf408886784224f67c99b4b9dbce2daf8a66dca1aa566d7f19b0444b749105 WHIRLPOOL c53e4a8fb5181317a9086859658e6c5ec00dcc8ba8cc55f4aea7a99ef032ec7482cd2f0f856028acd3649b4c5f126a821edbfe2f1d3d049cd6715862298d80cc
diff --git a/sci-libs/qd/files/qd-2.3.13-autotools.patch b/sci-libs/qd/files/qd-2.3.13-autotools.patch
new file mode 100644
index 000000000000..6a89cb6607b2
--- /dev/null
+++ b/sci-libs/qd/files/qd-2.3.13-autotools.patch
@@ -0,0 +1,15 @@
+ fortran/Makefile.am | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/fortran/Makefile.am b/fortran/Makefile.am
+index 1ab54f7..7889fa3 100644
+--- a/fortran/Makefile.am
++++ b/fortran/Makefile.am
+@@ -16,6 +16,7 @@ endif
+
+ lib_LTLIBRARIES = libqdmod.la libqd_f_main.la
+ libqdmod_la_SOURCES = ddext.f ddmod.f qdext.f qdmod.f f_dd.cpp f_qd.cpp
++libqdmod_la_LIBADD = $(FCLIBS)
+ libqd_f_main_la_SOURCES = main.cpp
+ ddmod.lo: $(DDEXT) ddext.lo
+ qdmod.lo: ddmod.lo $(DDMOD) qdext.lo
diff --git a/sci-libs/qd/metadata.xml b/sci-libs/qd/metadata.xml
new file mode 100644
index 000000000000..58f5d57d3cda
--- /dev/null
+++ b/sci-libs/qd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Quad-double and double-double float arithmetics</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/qd/qd-2.3.13.ebuild b/sci-libs/qd/qd-2.3.13.ebuild
new file mode 100644
index 000000000000..d1e9dfd10071
--- /dev/null
+++ b/sci-libs/qd/qd-2.3.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+FORTRAN_NEEDED=fortran
+
+inherit autotools-utils fortran-2
+
+DESCRIPTION="Quad-double and double-double float arithmetics"
+HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
+SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran static-libs"
+
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable fortran enable_fortran)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
+ dosym qd_real.h /usr/include/qd/qd.h
+ dosym dd_real.h /usr/include/qd/dd.h
+}
diff --git a/sci-libs/qd/qd-2.3.14.ebuild b/sci-libs/qd/qd-2.3.14.ebuild
new file mode 100644
index 000000000000..6d392eafa6ec
--- /dev/null
+++ b/sci-libs/qd/qd-2.3.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+FORTRAN_NEEDED=fortran
+
+inherit autotools-utils fortran-2
+
+DESCRIPTION="Quad-double and double-double float arithmetics"
+HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
+SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran static-libs"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.3.13-autotools.patch )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable fortran enable_fortran)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
+ dosym qd_real.h /usr/include/qd/qd.h
+ dosym dd_real.h /usr/include/qd/dd.h
+}