summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/taucs/files/taucs-2.2-respect-ar.patch')
-rw-r--r--sci-libs/taucs/files/taucs-2.2-respect-ar.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/taucs/files/taucs-2.2-respect-ar.patch b/sci-libs/taucs/files/taucs-2.2-respect-ar.patch
new file mode 100644
index 000000000000..4ab95441a2de
--- /dev/null
+++ b/sci-libs/taucs/files/taucs-2.2-respect-ar.patch
@@ -0,0 +1,22 @@
+--- a/config/linux.mk
++++ b/config/linux.mk
+@@ -25,7 +25,7 @@
+ LDFLAGS =
+ LOUTFLG = $(COUTFLG)
+
+-AR = ar cr
++ARFLAGS = cr
+ AOUTFLG =
+
+ RANLIB = ranlib
+--- a/configurator/taucs_config.c
++++ b/configurator/taucs_config.c
+@@ -558,7 +558,7 @@
+
+ fprintf(f, "%s: $(%s_content) $(STDDEPS)\n",get_full_name(i,0),base);
+ fprintf(f,"\t- $(RM) %s\n",get_full_name(i,0));
+- fprintf(f,"\t$(AR) $(AOUTFLG)%s $(%s_content)\n",get_full_name(i,0),base);
++ fprintf(f,"\t$(AR) $(ARFLAGS) $(AOUTFLG)%s $(%s_content)\n",get_full_name(i,0),base);
+ fprintf(f,"\t$(RANLIB) %s\n",get_full_name(i,0));
+ }
+