summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild')
-rw-r--r--sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild b/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild
new file mode 100644
index 000000000000..80fa329a76ce
--- /dev/null
+++ b/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic
+
+DESCRIPTION="A GiNaC-based library for symbolic expansion of certain transcendental functions"
+HOMEPAGE="http://wwwthep.physik.uni-mainz.de/~stefanw/nestedsums/"
+IUSE="doc"
+SRC_URI="http://wwwthep.physik.uni-mainz.de/~stefanw/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND=">=sci-mathematics/ginac-1.7"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ default
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen Doxyfile || die "generating documentation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -f "${D}"usr/lib/*.la
+ dodoc AUTHORS ChangeLog
+
+ if use doc; then
+ dohtml reference/html/*
+ fi
+}