summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/petsc/petsc-3.12.1.ebuild')
-rw-r--r--sci-mathematics/petsc/petsc-3.12.1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sci-mathematics/petsc/petsc-3.12.1.ebuild b/sci-mathematics/petsc/petsc-3.12.1.ebuild
index 2e5365823ea6..845d7ff75d69 100644
--- a/sci-mathematics/petsc/petsc-3.12.1.ebuild
+++ b/sci-mathematics/petsc/petsc-3.12.1.ebuild
@@ -159,23 +159,23 @@ src_configure() {
$(use_with hdf5) \
$(petsc_with hypre hypre \
/usr/include/hypre -lHYPRE) \
- $(petsc_with sparse suitesparse) \
+ $(use_with sparse suitesparse) \
$(petsc_with superlu superlu \
/usr/include/superlu -lsuperlu) \
- $(petsc_with X x) \
- $(petsc_with X x11) \
+ $(use_with X x) \
+ $(use_with X x11) \
$(petsc_with scotch ptscotch \
/usr/include/scotch \
[-lptesmumps,-lptscotch,-lptscotcherr,-lscotch,-lscotcherr]) \
$(petsc_with mumps scalapack \
/usr/include/scalapack -lscalapack) \
- $(petsc_with mumps mumps \
+ $(use_with mumps mumps \
/usr/include \
[-lcmumps,-ldmumps,-lsmumps,-lzmumps,-lmumps_common,-lpord]) \
--with-imagemagick=0 \
--with-python=0 \
- $(petsc_with boost) \
- $(petsc_with fftw)
+ $(use_with boost) \
+ $(use_with fftw)
}
src_install() {