summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/files/wxmaxima-require-wxGTK-3.0.patch8
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-17.10.1.ebuild11
2 files changed, 4 insertions, 15 deletions
diff --git a/sci-mathematics/wxmaxima/files/wxmaxima-require-wxGTK-3.0.patch b/sci-mathematics/wxmaxima/files/wxmaxima-require-wxGTK-3.0.patch
deleted file mode 100644
index b08434061d39..000000000000
--- a/sci-mathematics/wxmaxima/files/wxmaxima-require-wxGTK-3.0.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-diff -r -U3 wxmaxima-Version-17.10.1.orig/src/CMakeLists.txt wxmaxima-Version-17.10.1/src/CMakeLists.txt
---- wxmaxima-Version-17.10.1.orig/src/CMakeLists.txt 2017-10-22 12:45:56.000000000 +0700
-+++ wxmaxima-Version-17.10.1/src/CMakeLists.txt 2017-12-28 21:29:58.389806037 +0700
-@@ -1,3 +1,4 @@
-+set(wxWidgets_CONFIG_OPTIONS --toolkit=gtk2 --version=3.0)
- find_package(wxWidgets REQUIRED std xml html adv aui core net base richtext)
-
- include(${wxWidgets_USE_FILE})
diff --git a/sci-mathematics/wxmaxima/wxmaxima-17.10.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-17.10.1.ebuild
index 52fa2ddc14ed..c121ca2e948d 100644
--- a/sci-mathematics/wxmaxima/wxmaxima-17.10.1.ebuild
+++ b/sci-mathematics/wxmaxima/wxmaxima-17.10.1.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
+WX_GTK_VER="3.0"
PLOCALES="ca cs da de el es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
-inherit cmake-utils l10n xdg-utils gnome2-utils
+inherit cmake-utils wxwidgets l10n xdg-utils gnome2-utils
DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
HOMEPAGE="http://andrejv.github.io/wxmaxima/"
@@ -18,17 +18,14 @@ S="${WORKDIR}"/${PN}-Version-${PV}
DEPEND="
dev-libs/libxml2:2
- x11-libs/wxGTK:3.0"
+ x11-libs/wxGTK:${WX_GTK_VER}"
RDEPEND="${DEPEND}
media-fonts/jsmath
sci-visualization/gnuplot[wxwidgets]
sci-mathematics/maxima"
-PATCHES=(
- "${FILESDIR}"/${PN}-require-wxGTK-3.0.patch
-)
-
src_prepare() {
+ setup-wxwidgets
cmake-utils_src_prepare
sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i "${S}"/info/CMakeLists.txt \