summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/oww')
-rw-r--r--sci-misc/oww/Manifest2
-rw-r--r--sci-misc/oww/files/oww-0.86.4-build.patch79
-rw-r--r--sci-misc/oww/files/oww-0.86.5-format-security.patch30
-rw-r--r--sci-misc/oww/metadata.xml8
-rw-r--r--sci-misc/oww/oww-0.86.4.ebuild38
-rw-r--r--sci-misc/oww/oww-0.86.5.ebuild39
6 files changed, 196 insertions, 0 deletions
diff --git a/sci-misc/oww/Manifest b/sci-misc/oww/Manifest
new file mode 100644
index 000000000000..64848c90d30c
--- /dev/null
+++ b/sci-misc/oww/Manifest
@@ -0,0 +1,2 @@
+DIST oww-0.86.4.tar.gz 927032 SHA256 ad8347590d29d58dfa693ee1be0bf49a08bb8d1e065dc119e7f6624303262ae0 SHA512 b97ddd164fe81848e87466992414c8382a0f681bd8f1e16fc51a43facb73f073eb6b0c1da858f4d2d1ffc09273b05b6c3b526a1ccf1d572dbbfd3bfcd0742e05 WHIRLPOOL 82f3a61f25fcfe2e30fed4550b8d647010ab2a5c7ba8083341f3fee8157968a647df0361b08bfc55c76d7c150a249b53aba4dc886621eda0c7a64b3b24516968
+DIST oww-0.86.5.tar.gz 926962 SHA256 d374cfb421b8a421acd3d049b3ec6113e25ebfdf31a973143ee05ac69a8a30d6 SHA512 cc787379790367eea02423f5213a8947de906d6ccdebb1b76e97196e0be9d9f86e77fbc402693588ae4d7db69968caa7bc9e97e8dfc9395bf420d9df51b28ba9 WHIRLPOOL 2a777fe31116a16526851e8d8e7d60d8549c2db752d771b278cd1036e50c45e2508717fbd1541ff0bcc70302d98289a956c676d7ed3faa214ed29dd6b8c7c229
diff --git a/sci-misc/oww/files/oww-0.86.4-build.patch b/sci-misc/oww/files/oww-0.86.4-build.patch
new file mode 100644
index 000000000000..19f96a0c8551
--- /dev/null
+++ b/sci-misc/oww/files/oww-0.86.4-build.patch
@@ -0,0 +1,79 @@
+ Makefile.am | 3 +--
+ configure.in | 15 ++++++++-------
+ src/Makefile.am | 2 +-
+ 3 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index f90cc9d..36495a7 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,10 +5,9 @@
+
+ SUBDIRS = src pixmaps po
+
+-owwdocdir = ${prefix}/doc/oww
++owwdocdir = ${docdir}
+ owwdoc_DATA = \
+ README\
+- COPYING\
+ AUTHORS\
+ ChangeLog\
+ INSTALL\
+diff --git a/configure.in b/configure.in
+index dbc694e..a9c779f 100644
+--- a/configure.in
++++ b/configure.in
+@@ -6,6 +6,8 @@ AM_INIT_AUTOMAKE
+
+ AM_CONFIG_HEADER(config.h)
+
++AC_CONFIG_MACRO_DIR([.])
++
+ AC_ISC_POSIX
+ dnl CFLAGS=""
+ AC_SUBST(CFLAGS)
+@@ -134,17 +136,16 @@ else
+ AC_MSG_WARN(interactive CLI will not be build)
+ fi
+
+-AC_ARG_ENABLE(gui, , build_gui=no, build_gui=yes)
+-AM_CONDITIONAL(DISABLEGUI, test "x$build_gui" = "xno")
++AC_ARG_ENABLE([gui],AS_HELP_STRING([--disable-gui], [Do not build gtk gui]))
+
+-if test "$build_gui" = yes ; then
++AM_CONDITIONAL([DISABLEGUI], [test "x$enable_gui" != "xyes"])
++
++AS_IF([test "x$enable_gui" != "xno"], [
+ AC_MSG_WARN(building gui)
+ PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.4.0 gdk-2.0 gdk-pixbuf-2.0 gmodule-export-2.0,,exit)
+ AC_SUBST(GTK_LIBS)
+ AC_SUBST(GTK_CFLAGS)
+-else
+- AC_MSG_WARN(skipping GTK gui)
+-fi
++])
+
+ dnl How many times do we retry T on failure?
+ AC_ARG_ENABLE(temptries,
+@@ -319,7 +320,7 @@ cat<<EOF
+ ------------------------------
+ Oww version $VERSION by Simon Melhuish (simon@melhuish.info)
+
+- build_gui = $build_gui
++ build_gui = $xgui
+ interactive = $interactive
+ seriallock = $seriallock
+ USB support = $usb_msg
+diff --git a/src/Makefile.am b/src/Makefile.am
+index e0f6746..c02aab5 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -2,7 +2,7 @@
+
+ # Needs USB_CFLAGS here else things like musbllnk compile will fail if usb.h
+ # isn't in the compilers standard include path.
+-INCLUDES = \
++AM_CPPFLAGS = \
+ $(USB_CFLAGS)\
+ $(GTK_CFLAGS)
+
diff --git a/sci-misc/oww/files/oww-0.86.5-format-security.patch b/sci-misc/oww/files/oww-0.86.5-format-security.patch
new file mode 100644
index 000000000000..190c637e1983
--- /dev/null
+++ b/sci-misc/oww/files/oww-0.86.5-format-security.patch
@@ -0,0 +1,30 @@
+ src/file.c | 2 +-
+ src/werr_linux.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/file.c b/src/file.c
+index 9726564..af2f672 100644
+--- a/src/file.c
++++ b/src/file.c
+@@ -152,7 +152,7 @@ int file_check_file(char *file_name, int create)
+
+ fp = fopen(file_name, "w") ;
+ if (!fp) return 0 ;
+- fprintf(fp, setup_format_loghead) ;
++ fprintf(fp, "%s", setup_format_loghead) ;
+ fprintf(fp, "\n") ;
+ fclose(fp) ;
+ return 1 ;
+diff --git a/src/werr_linux.c b/src/werr_linux.c
+index 50d3993..0f8834e 100644
+--- a/src/werr_linux.c
++++ b/src/werr_linux.c
+@@ -331,7 +331,7 @@ void werr(int flags, char* format, ...)
+ else
+ syslog_level = LOG_DEBUG ;
+
+- syslog(syslog_level, message) ;
++ syslog(syslog_level, "%s", message) ;
+ }
+ # endif
+ # else // i.e. ifndef NOGUI
diff --git a/sci-misc/oww/metadata.xml b/sci-misc/oww/metadata.xml
new file mode 100644
index 000000000000..40818b6aa6b4
--- /dev/null
+++ b/sci-misc/oww/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <upstream>
+ <remote-id type="sourceforge">oww</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-misc/oww/oww-0.86.4.ebuild b/sci-misc/oww/oww-0.86.4.ebuild
new file mode 100644
index 000000000000..1f8ed82ebf0e
--- /dev/null
+++ b/sci-misc/oww/oww-0.86.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="A one-wire weather station for Dallas Semiconductor"
+HOMEPAGE="http://oww.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk nls usb"
+
+RDEPEND="
+ net-misc/curl
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ )
+
+src_configure() {
+ local myeconfargs=(
+ --enable-interactive
+ $(use_enable nls)
+ $(use_enable gtk gui)
+ $(use_with usb)
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-misc/oww/oww-0.86.5.ebuild b/sci-misc/oww/oww-0.86.5.ebuild
new file mode 100644
index 000000000000..d94afc32cfd6
--- /dev/null
+++ b/sci-misc/oww/oww-0.86.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="A one-wire weather station for Dallas Semiconductor"
+HOMEPAGE="http://oww.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk nls usb"
+
+RDEPEND="
+ net-misc/curl
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.86.4-build.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ )
+
+src_configure() {
+ local myeconfargs=(
+ --enable-interactive
+ $(use_enable nls)
+ $(use_enable gtk gui)
+ $(use_with usb)
+ )
+ autotools-utils_src_configure
+}