summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/repsnapper/repsnapper-9999.ebuild')
-rw-r--r--sci-misc/repsnapper/repsnapper-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-misc/repsnapper/repsnapper-9999.ebuild b/sci-misc/repsnapper/repsnapper-9999.ebuild
new file mode 100644
index 000000000000..3d04fe6ee6c5
--- /dev/null
+++ b/sci-misc/repsnapper/repsnapper-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools git-2
+
+DESCRIPTION="Host software for controlling the RepRap open source 3D printer"
+HOMEPAGE="https://github.com/timschmidt/repsnapper"
+EGIT_REPO_URI="git://github.com/timschmidt/${PN}.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ >=dev-cpp/gtkglextmm-1.2
+ >=dev-cpp/gtkmm-2.4
+ dev-cpp/libxmlpp
+ dev-libs/libzip
+ virtual/opengl
+"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ eautoreconf
+}