summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/vitables')
-rw-r--r--sci-misc/vitables/files/vitables-2.1-no-docs.patch4
-rw-r--r--sci-misc/vitables/vitables-2.1-r1.ebuild52
2 files changed, 54 insertions, 2 deletions
diff --git a/sci-misc/vitables/files/vitables-2.1-no-docs.patch b/sci-misc/vitables/files/vitables-2.1-no-docs.patch
index 307fb65b043c..0d76e264f79e 100644
--- a/sci-misc/vitables/files/vitables-2.1-no-docs.patch
+++ b/sci-misc/vitables/files/vitables-2.1-no-docs.patch
@@ -1,5 +1,5 @@
---- setup.py.orig 2011-02-15 11:05:17.000000000 -0800
-+++ setup.py 2012-08-04 12:00:40.704723726 -0700
+--- a/setup.py
++++ b/setup.py
@@ -34,13 +34,14 @@
from distutils.dir_util import copy_tree
from distutils.file_util import copy_file
diff --git a/sci-misc/vitables/vitables-2.1-r1.ebuild b/sci-misc/vitables/vitables-2.1-r1.ebuild
new file mode 100644
index 000000000000..5d9caccf2e06
--- /dev/null
+++ b/sci-misc/vitables/vitables-2.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P=ViTables-${PV}
+
+DESCRIPTION="A graphical tool for browsing / editing files in both PyTables and HDF5 formats"
+HOMEPAGE="http://vitables.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ dev-python/pytables
+ dev-python/PyQt4[X]" # FIXME: check if any other useflags are needed
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-no-docs.patch )
+
+python_compile_all() {
+ distutils-r1_python_compile
+ # fixme: multiple python (anyone cares?)
+ use doc && esetup.py build_sphinx
+}
+
+python_install_all() {
+ dodir /usr/share/icons/hicolor/scalable/apps
+ dodir /usr/share/applications
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ DOCS+=( examples )
+ fi
+ if use doc ; then
+ HTML_DOCS+=( "${BUILD_DIR}"/sphinx/html/. )
+ DOCS+=( "${BUILD_DIR}"/sphinx/latex/*.pdf )
+ fi
+ einstalldocs
+}