summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/root/files/root-6.00.01-llvm.patch')
-rw-r--r--sci-physics/root/files/root-6.00.01-llvm.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/sci-physics/root/files/root-6.00.01-llvm.patch b/sci-physics/root/files/root-6.00.01-llvm.patch
new file mode 100644
index 000000000000..c6abb353ee64
--- /dev/null
+++ b/sci-physics/root/files/root-6.00.01-llvm.patch
@@ -0,0 +1,13 @@
+diff --git a/interpreter/llvm/src/Makefile.config.in b/interpreter/llvm/src/Makefile.config.in
+index 7633be2..c8756b1 100644
+--- a/interpreter/llvm/src/Makefile.config.in
++++ b/interpreter/llvm/src/Makefile.config.in
+@@ -170,6 +170,8 @@ CXXFLAGS += @CXXFLAGS@
+
+ # Linker flags.
+ LDFLAGS += @LDFLAGS@
++NOUNDEF := -Wl,--no-undefined
++LDFLAGS := $(filter-out $(NOUNDEF),$(LDFLAGS))
+
+ # Path to the library archiver program.
+ AR_PATH = @AR@