summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/yoda/yoda-1.6.5.ebuild')
-rw-r--r--sci-physics/yoda/yoda-1.6.5.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sci-physics/yoda/yoda-1.6.5.ebuild b/sci-physics/yoda/yoda-1.6.5.ebuild
deleted file mode 100644
index 82bf586a70b0..000000000000
--- a/sci-physics/yoda/yoda-1.6.5.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit bash-completion-r1 python-single-r1
-
-DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
-HOMEPAGE="http://yoda.hepforge.org/"
-
-SRC_URI="http://www.hepforge.org/archive/${PN}/${P^^}.tar.bz2"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="python root static-libs"
-
-RDEPEND="
- dev-libs/boost:=
- python? ( ${PYTHON_DEPS} )
- root? ( sci-physics/root:=[python=,${PYTHON_SINGLE_USEDEP}] )"
-DEPEND="${RDEPEND}
- python? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_MULTI_USEDEP}]
- ')
- )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-S="${WORKDIR}/${P^^}"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- econf \
- $(use_enable python pyext) \
- $(use_enable root) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- newbashcomp "${ED%/}"/usr/share/YODA/yoda-completion ${PN}
- rm "${ED%/}"/usr/share/YODA/yoda-completion || die
-}