summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/yoda/yoda-1.6.5.ebuild10
-rw-r--r--sci-physics/yoda/yoda-1.7.0-r1.ebuild (renamed from sci-physics/yoda/yoda-1.7.0.ebuild)10
2 files changed, 14 insertions, 6 deletions
diff --git a/sci-physics/yoda/yoda-1.6.5.ebuild b/sci-physics/yoda/yoda-1.6.5.ebuild
index 00d3f8949c26..82bf586a70b0 100644
--- a/sci-physics/yoda/yoda-1.6.5.ebuild
+++ b/sci-physics/yoda/yoda-1.6.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,9 +20,13 @@ IUSE="python root static-libs"
RDEPEND="
dev-libs/boost:=
python? ( ${PYTHON_DEPS} )
- root? ( sci-physics/root:=[python=,${PYTHON_USEDEP}] )"
+ root? ( sci-physics/root:=[python=,${PYTHON_SINGLE_USEDEP}] )"
DEPEND="${RDEPEND}
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
diff --git a/sci-physics/yoda/yoda-1.7.0.ebuild b/sci-physics/yoda/yoda-1.7.0-r1.ebuild
index 9f53d934f26e..a29234715ba0 100644
--- a/sci-physics/yoda/yoda-1.7.0.ebuild
+++ b/sci-physics/yoda/yoda-1.7.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,9 +19,13 @@ IUSE="python root static-libs"
RDEPEND="
python? ( ${PYTHON_DEPS} )
- root? ( sci-physics/root:=[python=,${PYTHON_USEDEP}] )"
+ root? ( sci-physics/root:=[python=,${PYTHON_SINGLE_USEDEP}] )"
DEPEND="${RDEPEND}
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"