summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/spectromatic/spectromatic-1.0-r3.ebuild')
-rw-r--r--sci-visualization/spectromatic/spectromatic-1.0-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-visualization/spectromatic/spectromatic-1.0-r3.ebuild b/sci-visualization/spectromatic/spectromatic-1.0-r3.ebuild
new file mode 100644
index 000000000000..10d366ad3c77
--- /dev/null
+++ b/sci-visualization/spectromatic/spectromatic-1.0-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_P=${PN}_${PV}-1
+
+DESCRIPTION="Generates time-frequency analysis images from wav files"
+HOMEPAGE="http://ieee.uow.edu.au/~daniel/software/spectromatic/"
+SRC_URI="http://ieee.uow.edu.au/~daniel/software/spectromatic/dist/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ media-libs/libpng:0=
+ sci-libs/gsl:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-stringliteral.patch
+ "${FILESDIR}"/${P}-waveheaderstruct-amd64.patch
+)
+
+src_configure() {
+ tc-export CC
+ export TOPLEVEL_HOME="${EPREFIX}/usr"
+}