summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/yt/yt-3.3.2.ebuild')
-rw-r--r--sci-visualization/yt/yt-3.3.2.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/sci-visualization/yt/yt-3.3.2.ebuild b/sci-visualization/yt/yt-3.3.2.ebuild
deleted file mode 100644
index 0ff81757f9b8..000000000000
--- a/sci-visualization/yt/yt-3.3.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Astrophysical Simulation Analysis and Vizualization package"
-HOMEPAGE="http://yt-project.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-CDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/sympy[${PYTHON_USEDEP}]"
-# dev-python/pyx[${PYTHON_USEDEP}]
-DEPEND="${CDEPEND}
- >=dev-python/cython-0.24[${PYTHON_USEDEP}]
- >=dev-python/setuptools-20.0[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- append-flags -fno-strict-aliasing
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib > /dev/null
- nosetests -sv || die "Tests fail with ${EPYTHON} ${PWD}"
- popd > /dev/null
-}