summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/acl/acl-2.2.53-r1.ebuild')
-rw-r--r--sys-apps/acl/acl-2.2.53-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/acl/acl-2.2.53-r1.ebuild b/sys-apps/acl/acl-2.2.53-r1.ebuild
index 261639dbb408..36ef9c8cb34a 100644
--- a/sys-apps/acl/acl-2.2.53-r1.ebuild
+++ b/sys-apps/acl/acl-2.2.53-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,6 +41,12 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
+multilib_src_test() {
+ # Tests call native binaries with an LD_PRELOAD wrapper
+ # https://bugs.gentoo.org/772356
+ multilib_is_native_abi && default
+}
+
multilib_src_install() {
default