summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/biosdevname/biosdevname-0.3.11-r1.ebuild')
-rw-r--r--sys-apps/biosdevname/biosdevname-0.3.11-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/biosdevname/biosdevname-0.3.11-r1.ebuild b/sys-apps/biosdevname/biosdevname-0.3.11-r1.ebuild
new file mode 100644
index 000000000000..cc48a0776f54
--- /dev/null
+++ b/sys-apps/biosdevname/biosdevname-0.3.11-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Sets BIOS-given device names instead of kernel eth* names"
+HOMEPAGE="http://linux.dell.com/biosdevname/"
+SRC_URI="http://linux.dell.com/biosdevname/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CDEPEND="virtual/udev"
+DEPEND="${CDEPEND}
+ sys-apps/pciutils"
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ sed -e 's|/sbin/biosdevname|/usr\0|g' -i "${S}"/biosdevname.rules.in
+}
+
+pkg_postinst() {
+ elog "To make it working you need to remove"
+ elog ""
+ elog " /etc/udev/rules.d/70-persistent-net.rules"
+ elog ""
+ elog "and then reboot the machine. After reboot ethernet devices names will"
+ elog "change to the ones reported by BIOS. For more information you might"
+ elog "want to read following document:"
+ elog ""
+ elog " http://fedoraproject.org/wiki/Features/ConsistentNetworkDeviceNaming"
+ elog ""
+ elog "To disable this feature, pass biosdevname=0 to kernel command line."
+ elog ""
+ elog "If you use Dracut, you might want to enable 'biosdevname' module"
+ elog "(in DRACUT_MODULES variable)."
+}