summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dchroot/dchroot-0.12.1.ebuild')
-rw-r--r--sys-apps/dchroot/dchroot-0.12.1.ebuild25
1 files changed, 8 insertions, 17 deletions
diff --git a/sys-apps/dchroot/dchroot-0.12.1.ebuild b/sys-apps/dchroot/dchroot-0.12.1.ebuild
index 7f02674ae0ae..fef8cb146e1d 100644
--- a/sys-apps/dchroot/dchroot-0.12.1.ebuild
+++ b/sys-apps/dchroot/dchroot-0.12.1.ebuild
@@ -1,36 +1,27 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit toolchain-funcs
+inherit autotools
DESCRIPTION="Utility for managing chroots for non-root users"
-HOMEPAGE="https://packages.debian.org/unstable/admin/dchroot"
-SRC_URI="mirror://debian/pool/main/d/dchroot/dchroot_${PV}.tar.gz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P/-/_}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="sys-apps/help2man"
RDEPEND="!dev-util/schroot[dchroot]"
+BDEPEND="sys-apps/help2man"
PATCHES=(
- "${FILESDIR}"/${PN}-0.12.1-no-werror.patch
+ "${FILESDIR}"/${P}-make.patch
)
src_prepare() {
- sed -i \
- -e '/^all:/s:$: docs:' \
- -e '/^CFLAGS/s:-O2:@CFLAGS@:' \
- -e '/@CFLAGS@/ s:@CFLAGS@:@CFLAGS@ @LDFLAGS@:' \
- Makefile.in || die "sed failed"
-
default
-}
-src_compile() {
- emake CC="$(tc-getCC)"
+ eautoreconf #874318
}