summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dnotify/dnotify-0.18.0-r1.ebuild')
-rw-r--r--sys-apps/dnotify/dnotify-0.18.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-apps/dnotify/dnotify-0.18.0-r1.ebuild b/sys-apps/dnotify/dnotify-0.18.0-r1.ebuild
new file mode 100644
index 000000000000..b92ef1d92179
--- /dev/null
+++ b/sys-apps/dnotify/dnotify-0.18.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Execute a command when the contents of a directory change"
+HOMEPAGE="https://directory.fsf.org/project/dnotify/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc -sparc x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-nls.patch"
+ "${FILESDIR}/${P}-glibc-212.patch"
+)
+
+src_configure() {
+ econf $(use_enable nls)
+}