summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild12
1 files changed, 2 insertions, 10 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
index 9241ede6e058..0e2f5f5dbcfc 100644
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
@@ -24,6 +24,8 @@ IUSE=""
RDEPEND=">=sys-apps/systemd-207
!sys-fs/eudev
!sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207
+ virtual/pkgconfig"
if [[ ${PV} == 9999 ]]; then
DEPEND+=" sys-devel/systemd-m4"
@@ -33,13 +35,3 @@ src_prepare() {
default
[[ ${PV} != 9999 ]] || eautoreconf
}
-
-src_configure() {
- local myeconfargs=(
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
- # TODO: solve it better in the eclass
- --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
- )
-
- econf "${myeconfargs[@]}"
-}