summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hardened-shadow')
-rw-r--r--sys-apps/hardened-shadow/Manifest1
-rw-r--r--sys-apps/hardened-shadow/hardened-shadow-0.9.2.ebuild36
-rw-r--r--sys-apps/hardened-shadow/metadata.xml11
3 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/hardened-shadow/Manifest b/sys-apps/hardened-shadow/Manifest
new file mode 100644
index 000000000000..a8cea00a83f3
--- /dev/null
+++ b/sys-apps/hardened-shadow/Manifest
@@ -0,0 +1 @@
+DIST hardened-shadow-0.9.2.tar.gz 393648 SHA256 0561bf7059b3de7e97e968bb71a3ccac3dd944bf96f1d5de87798359e592aa00
diff --git a/sys-apps/hardened-shadow/hardened-shadow-0.9.2.ebuild b/sys-apps/hardened-shadow/hardened-shadow-0.9.2.ebuild
new file mode 100644
index 000000000000..e005e84b1336
--- /dev/null
+++ b/sys-apps/hardened-shadow/hardened-shadow-0.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils eutils multilib user
+
+DESCRIPTION="Hardened implementation of user account utilities"
+HOMEPAGE="http://code.google.com/p/hardened-shadow/"
+SRC_URI="http://hardened-shadow.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-libs/pam
+ !sys-apps/shadow"
+RDEPEND="${DEPEND}
+ >=sys-auth/pambase-20120417"
+
+DOCS=( README )
+
+pkg_setup() {
+ # The hardened-shadow group is needed at src_install time,
+ # so the only place we can create the group is pkg_setup.
+ enewgroup hardened-shadow
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # Remove pam.d files colliding with pambase.
+ rm -r "${ED}"/etc/pam.d || die
+}
diff --git a/sys-apps/hardened-shadow/metadata.xml b/sys-apps/hardened-shadow/metadata.xml
new file mode 100644
index 000000000000..5dcc2c69c794
--- /dev/null
+++ b/sys-apps/hardened-shadow/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>phajdan.jr@gentoo.org</email>
+ <name>Pawel Hajdan jr</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">hardened-shadow</remote-id>
+ </upstream>
+</pkgmetadata>