summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hwdata-redhat')
-rw-r--r--sys-apps/hwdata-redhat/Manifest1
-rw-r--r--sys-apps/hwdata-redhat/files/hwdata-redhat-0.217-python-3.patch13
-rw-r--r--sys-apps/hwdata-redhat/hwdata-redhat-0.217.ebuild39
-rw-r--r--sys-apps/hwdata-redhat/metadata.xml8
4 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/hwdata-redhat/Manifest b/sys-apps/hwdata-redhat/Manifest
new file mode 100644
index 000000000000..ea2ba5c3b767
--- /dev/null
+++ b/sys-apps/hwdata-redhat/Manifest
@@ -0,0 +1 @@
+DIST hwdata-0.217-1.fc9.src.rpm 735079 SHA256 f2b6f3223cb388b9ff261ca84ed93b9e5eba95be62b7377ff685708351d377ad
diff --git a/sys-apps/hwdata-redhat/files/hwdata-redhat-0.217-python-3.patch b/sys-apps/hwdata-redhat/files/hwdata-redhat-0.217-python-3.patch
new file mode 100644
index 000000000000..f16fddd992c4
--- /dev/null
+++ b/sys-apps/hwdata-redhat/files/hwdata-redhat-0.217-python-3.patch
@@ -0,0 +1,13 @@
+--- check-pci-ids.py
++++ check-pci-ids.py
+@@ -5,8 +5,8 @@
+
+ # Check that the sorting order is preserved in pci.ids
+
+-vendor_id = None
+-device_id = None
++vendor_id = -1
++device_id = -1
+ lineno = 1
+
+ file = open("pci.ids")
diff --git a/sys-apps/hwdata-redhat/hwdata-redhat-0.217.ebuild b/sys-apps/hwdata-redhat/hwdata-redhat-0.217.ebuild
new file mode 100644
index 000000000000..7c1d9740df22
--- /dev/null
+++ b/sys-apps/hwdata-redhat/hwdata-redhat-0.217.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic rpm
+
+# Tag for which Fedora Core version it's from
+FCVER="9"
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+MY_P="${P/-redhat}"
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora-dev/releases/9/Everything/source/SRPMS/${MY_P}-${RPMREV}.fc${FCVER}.src.rpm"
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64 ~x86 ~amd64"
+IUSE="test"
+RDEPEND="virtual/modutils
+ !sys-apps/hwdata-gentoo"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/pciutils )"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ rpm_src_unpack ${A}
+
+ cd "${S}"
+ sed -i -e "s:\(/sbin\/lspci\):/usr\1:g" Makefile || die
+ epatch "${FILESDIR}/${P}-python-3.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # Don't let it overwrite a udev-installed file
+ rm -rf "${D}"/etc/ || die
+}
diff --git a/sys-apps/hwdata-redhat/metadata.xml b/sys-apps/hwdata-redhat/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/sys-apps/hwdata-redhat/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>