summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/lsadb/lsadb-0.1.3.ebuild')
-rw-r--r--sys-apps/lsadb/lsadb-0.1.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/lsadb/lsadb-0.1.3.ebuild b/sys-apps/lsadb/lsadb-0.1.3.ebuild
new file mode 100644
index 000000000000..2f3b2766e9f1
--- /dev/null
+++ b/sys-apps/lsadb/lsadb-0.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Prints out information on all devices attached to the ADB bus"
+HOMEPAGE="http://pbbuttons.berlios.de/projects/lsadb/"
+SRC_URI="mirror://berlios/pub/pbbuttons/${PN}-${PV}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~ppc"
+IUSE=""
+DEPEND=""
+RDEPEND="$DEPEND"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin lsadb
+ doman lsadb.1
+ dodoc README
+}